Codeup《算法笔记》9.2小节——数据结构专题(2)->二叉树的遍历->Problem D:二叉树的遍历

Problem D: 二叉树遍历
[Creator : Imported]
Time Limit : 1.000 sec Memory Limit : 32 MB

Description

编一个程序,读入用户输入的一串先序遍历字符串,根据此字符串建立一个二叉树(以指针方式存储)。
例如如下的先序遍历字符串:
ABC##DE#G##F###
其中“#”表示的是空格,空格字符代表空树。建立起此二叉树以后,再对二叉树进行中序遍历,输出遍历结果。

Input

输入包括1行字符串,长度不超过100。

Output

可能有多组测试数据,对于每组数据,
输出将输入字符串建立二叉树后中序遍历的序列,每个字符后面都有一个空格。
每个输出结果占一行。

Sample Input Copy

a#b#cdef#####
a##

Sample Output Copy

a b f e d c
a

思路分析:

题目已经给了一个先序遍历的序列,根据这个序列构造出一个二叉树,然后中序遍历就可了;

#include <iostream>
#include <algorithm>
#include <math.h>
using namespace std;
const int maxn=200;
char per[maxn];
int index=0;
struct Node{
	char data;//数据域
	Node *lchild; //左右孩子结点 
	Node *rchild; 
};
void mid_View(Node *root){ //中序遍历 
	if(root==NULL){
		return ;
	}
	mid_View(root->lchild);
	printf("%c ",root->data);
	mid_View(root->rchild);
}
Node *creat(){ //有先序遍历构造二叉树 
	if(per[index]=='#'){
		index++;
		return NULL;
	}
	Node *root=new Node;
	root->data=per[index];
	index++;
	root->lchild=creat();
	root->rchild=creat();
	return root;
}
int main()
{
	while(scanf("%s",per)!=EOF){
	index=0;
	mid_View(creat());
	cout<<endl;
	}
}
/**************************************************************
    Problem: 2014
    User: Jccober
    Language: C++
    Result: Accepted
    Time:0 ms
    Memory:1700 kb
****************************************************************/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值