You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.
Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.
Output
You need to answer all Q commands in order. One answer in a line.
Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
**
The sums may exceed the range of 32-bit integers.
区间求和、成段加减
**
#include<iostream>
#include<math.h>
#include<algorithm>
using namespace std;
const int maxn = 1e5+10 ;
const int INF = 0x3f3f3f3f;
long long sum[maxn*4],a[maxn*4],k,c[maxn];
int t,n,m,nn,mm,zz;
char ch[10];
void push_up(int x){//左儿子+右儿子
sum[x] = sum[x<<1]+sum[x<<1|1];
}
void pushdown(int x,int l,int r){//更新sum
if(a[x]){
int mid=(l+r)>>1;
a[x<<1]+=a[x];
a[x<<1|1]+=a[x];
sum[x<<1]+=(mid-l+1)*a[x];
sum[x<<1|1]+=(r-mid)*a[x];
a[x]=0;
}
}
void build(int l,int r,int x){//递归建树
int mid=(l+r)>>1;
a[x]=0;
if(l==r){
scanf("%lld",&sum[x]);
return ;
}
build(l,mid,x<<1);
build(mid+1,r,x<<1|1);
push_up(x);
}
void update(int l,int r,int z,int ll,int rr,int x){
int mid = (ll+rr)>>1;
if(l<=ll&&rr<=r){
a[x] += z;
sum[x] += (long long)z*(rr-ll+1);
return ;
}
pushdown(x,ll,rr);
if(l<=mid) update(l,r,z,ll,mid,x<<1);
if(mid<r) update(l,r,z,mid+1,rr,x<<1|1);
push_up(x);
}
long long query(int l,int r,int ll,int rr,int x){
if(l<=ll&&rr<=r) return sum[x];
pushdown(x,ll,rr);
int m=(ll+rr)>>1;
long long ans=0;
if(l<=m) ans+=query(l,r,ll,m,x<<1);
if(r>m) ans+=query(l,r,m+1,rr,x<<1|1);
return ans;
}
int main(){
cin>>n>>m;
build(1,n,1);
while(m--){
cin>>ch;
if(ch[0]=='Q'){
cin>>nn>>mm;
cout<<query(nn,mm,1,n,1)<<endl;
}
else{
cin>>nn>>mm>>zz;
update(nn,mm,zz,1,n,1);
}
}
}