Just a Hook -线段树-更换再求和

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length. 



Now Pudge wants to do some operations on the hook. 

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks. 
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows: 

For each cupreous stick, the value is 1. 
For each silver stick, the value is 2. 
For each golden stick, the value is 3. 

Pudge wants to know the total value of the hook after performing the operations. 
You may consider the original hook is made up of cupreous sticks. 

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases. 
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations. 
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind. 

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example. 

Sample Input

1
10
2
1 5 2
5 9 3

Sample Output

Case 1: The total value of the hook is 24.

题意:第一行有t个测试用例,第二行表示有n根棍子,每根棍子最初价值为1,第三行代表有m次操作,以下m行每行a,b,c

表示在区间[a,b]内,每根棍子价值将被替换成c,问经过m次操作后,所有棍子的价值和为多少

分析:线段树模板,替换给定区间的一段值后求所有数的和,求和问题

Select Code

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define ll long long
using namespace std;
ll q[100010];
struct Ti
{
    long long l,r,sum,lazy;
}t[100010*4];
void up(ll k)//更新子节点的父节点
{
    t[k].sum=t[k<<1].sum+t[k<<1|1].sum;
}
void pushdown(ll k)
{
    if(t[k].lazy)
    {
        t[k<<1].lazy=t[k].lazy;//这里是替换,不要写成+=,以下几行也是
        t[k<<1|1].lazy=t[k].lazy;
        t[k<<1].sum=t[k].lazy*(t[k<<1].r-t[k<<1].l+1);
        t[k<<1|1].sum=t[k].lazy*(t[k<<1|1].r-t[k<<1|1].l+1);
        t[k].lazy=0;
    }
}
void build(ll l,ll r,ll k)//建树
{
    t[k].lazy = 0;
    t[k].l=l;
    t[k].r=r;
    if(l == r) {
        t[k].sum=q[r];
        return;
    }
    ll mid = (l + r) >> 1;
    build(l,mid,k<<1);
    build(mid+1,r,k<<1|1);
    up(k);
}
void update(ll l,ll r,ll v,ll k)//更新
{
    if(l<=t[k].l&&r>=t[k].r)
    {
        t[k].sum=v*(t[k].r-t[k].l+1);//不要写成+=,因为是替换,不是原基础上加
        t[k].lazy=v;
        return;
    }
    pushdown(k);
    ll mid=(t[k].l+t[k].r)/2;
    if(l<=mid)
       update(l,r,v,k*2);
    if(r>mid)
        update(l,r,v,2*k+1);
    up(k);
}
ll query(ll l,ll r,ll k)//查询求和
{
    if(l<=t[k].l&&r>=t[k].r)
        return t[k].sum;
    pushdown(k);
    ll mid=(t[k].l+t[k].r)/2,ans=0;
    if(l<=mid)
        ans+=query(l,r,k*2);
    if(r>mid)
        ans+=query(l,r,k*2+1);
    return ans;
}
int main()
{
    ll t,n,i,h;
    scanf("%lld",&t);
    for(h=1;h<=t;h++)
    {
        scanf("%lld",&n);
        for(i=0;i<=n;i++)
            q[i]=1;
        build(1,n,1);
        ll m;
        scanf("%lld",&m);
        ll x1,x2,v1;
        while(m--)
        {
            scanf("%lld%lld%lld",&x1,&x2,&v1);
            update(x1,x2,v1,1);
        }
        printf("Case %lld: The total value of the hook is %lld.\n",h,query(1,n,1));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值