Description
You are trapped in a 3D dungeon and need to find the quickest way out!
The dungeon is composed of unit cubes which may or may not be filled
with rock. It takes one minute to move one unit north, south, east,
west, up or down. You cannot move diagonally and the maze is
surrounded by solid rock on all sides.
Is an escape possible? If yes, how long will it take?
Input
The input consists of a number of dungeons. Each dungeon description
starts with a line containing three integers L, R and C (all limited
to 30 in size). L is the number of levels making up the dungeon. R and
C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C
characters. Each character describes one cell of the dungeon. A cell
full of rock is indicated by a ‘#’ and empty cells are represented by
a ‘.’. Your starting position is indicated by ‘S’ and the exit by the
letter ‘E’. There’s a single blank line after each level. Input is
terminated by three zeroes for L, R and C.
Output
Each maze generates one line of output. If it is possible to reach the
exit, print a line of the form
Escaped in x minute(s).where x is replaced by the shortest time it takes to escape. If it is
not possible to escape, print the line
Trapped!
Sample Input
3 4 5
S....
.###.
.##..
###.#
#####
#####
##.##
##...
#####
#####
#.###
####E
1 3 3
S##
#E#
###
0 0 0
Sample Output
Escaped in 11 minute(s).
Trapped!
#include<iostream>
#include<stdio.h>
#include<string>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;
char maze[32][32][32];
struct dungeons
{
int l, r, c;
dungeons(int a, int b, int c) :l(a), r(b), c(c) {};
dungeons() {};
};
//定义六个移动方向
dungeons direction[6] = { dungeons(-1,0,0), dungeons(1,0,0) , dungeons(0,1,0) , dungeons(0,-1,0), dungeons(0,0,1) , dungeons(0,0,-1) };
dungeons operator+(dungeons a, dungeons b)
{
dungeons ans;
ans.l = a.l + b.l;
ans.r = a.r + b.r;
ans.c = a.c + b.c;
return ans;
}
dungeons start;
int bfs()
{
queue<pair<dungeons, int>>q;
q.push(make_pair(start,0));
while (!q.empty())
{
pair<dungeons, int> head = q.front();
q.pop();
if (maze[head.first.l][head.first.r][head.first.c] == 'E')
return head.second;
for (int i = 0; i < 6; i++)
{
dungeons next = head.first + direction[i];
if (maze[next.l][next.r][next.c] == 'E')
return head.second + 1;
if (maze[next.l][next.r][next.c] == '.')
{
q.push(make_pair(next, head.second + 1));
maze[next.l][next.r][next.c] = '#';
}
}
}
return 0x7fffffff;
}
int main()
{
int L, R, C;
//scanf("%d%d%d\n", &L, &R, &C) != EOF
while (cin >> L >> R >> C)
{
if (L == 0 && R == 0 && C == 0)
break;
memset(maze, '#', sizeof(maze));
for (int i = 1; i <= L; i++)
{
for (int j = 1; j <= R; j++)
{
for (int k = 1; k <= C; k++)
{
//scanf("%c", &maze[i][j][k]);
cin >> maze[i][j][k];
if (maze[i][j][k] == 'S')
{
start.l = i;
start.r = j;
start.c = k;
maze[i][j][k] = '#';
}
}
}
}
int ans = bfs();
if (ans != 0x7fffffff)
cout << "Escaped in " << ans << " minute(s)." << endl;
else
cout << "Trapped!" << endl;
}
return 0;
}