POJ-2251:Dungeon Master(C++详细代码实现)

Description

You are trapped in a 3D dungeon and need to find the quickest way out!
The dungeon is composed of unit cubes which may or may not be filled
with rock. It takes one minute to move one unit north, south, east,
west, up or down. You cannot move diagonally and the maze is
surrounded by solid rock on all sides.
Is an escape possible? If yes, how long will it take?

Input

The input consists of a number of dungeons. Each dungeon description
starts with a line containing three integers L, R and C (all limited
to 30 in size). L is the number of levels making up the dungeon. R and
C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C
characters. Each character describes one cell of the dungeon. A cell
full of rock is indicated by a ‘#’ and empty cells are represented by
a ‘.’. Your starting position is indicated by ‘S’ and the exit by the
letter ‘E’. There’s a single blank line after each level. Input is
terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the
exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. If it is
not possible to escape, print the line
Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###


0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!
#include<iostream>
#include<stdio.h>
#include<string>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;
char maze[32][32][32];
struct dungeons
{
	int l, r, c;
	dungeons(int a, int b, int c) :l(a), r(b), c(c) {};
	dungeons() {};
};
//定义六个移动方向
dungeons direction[6] = { dungeons(-1,0,0), dungeons(1,0,0) , dungeons(0,1,0) , dungeons(0,-1,0), dungeons(0,0,1) , dungeons(0,0,-1) };
dungeons operator+(dungeons a, dungeons b)
{
	dungeons ans;
	ans.l = a.l + b.l;
	ans.r = a.r + b.r;
	ans.c = a.c + b.c;
	return ans;
}
dungeons start;
int bfs()
{
	queue<pair<dungeons, int>>q;
	q.push(make_pair(start,0));
	while (!q.empty())
	{
		pair<dungeons, int> head = q.front();
		q.pop();
		if (maze[head.first.l][head.first.r][head.first.c] == 'E')
			return head.second;
		for (int i = 0; i < 6; i++)
		{
			dungeons next = head.first + direction[i];
			if (maze[next.l][next.r][next.c] == 'E')
				return head.second + 1;
			if (maze[next.l][next.r][next.c] == '.')
			{
				q.push(make_pair(next, head.second + 1));
				maze[next.l][next.r][next.c] = '#';
			}
		}
	}
	return 0x7fffffff;
}
int main()
{
	int L, R, C;
	//scanf("%d%d%d\n", &L, &R, &C) != EOF
	while (cin >> L >> R >> C)
	{
		if (L == 0 && R == 0 && C == 0)
			break;
		memset(maze, '#', sizeof(maze));
		for (int i = 1; i <= L; i++)
		{
			for (int j = 1; j <= R; j++)
			{
				for (int k = 1; k <= C; k++)
				{
					//scanf("%c", &maze[i][j][k]);
					cin >> maze[i][j][k];
					if (maze[i][j][k] == 'S')
					{
						start.l = i;
						start.r = j;
						start.c = k;
						maze[i][j][k] = '#';
					}
				}
			}
		}
		int ans = bfs();
		if (ans != 0x7fffffff)
			cout << "Escaped in " << ans << " minute(s)." << endl;
		else
			cout << "Trapped!" << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

艺千秋录

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值