Description
给定两个字符串A和B, 请计算这两人个字符串的最长公共子序列长度。
Input
第一行输入M(M<=10)表示有M组数据。每组数据输入两行字符串, 字符串的长度不长于500。
Output
输出M行正整数,第i行表示第i组数据的最长公共子序列长度。
Sample Input
2
abcdefg
cemg
abcdefgh
ceaaegh
Sample Output
3
4
#include "iostream"
#include "cstring"
using namespace std;
const int N=510;
int f[N][N]; // 从字符串1的前i个字符,字符串2的前j个字符中选,最大公共字串的数量
int getResult(string& str1, string& str2) {
for (int i = 1; i <= str1.size(); ++i) {
for (int j = 1; j <= str2.size(); ++j) {
if(str1[i-1]==str2[j-1]){
f[i][j] = f[i-1][j-1]+1;
}else{
f[i][j] = max(f[i-1][j],f[i][j-1]);
}
}
}
return f[str1.size()][str2.size()];
}
int main(){
int M;
cin >> M;
while (M--){
string str1;
string str2;
cin>> str1;
cin>> str2;
memset(f,0,sizeof f);
cout<<getResult(str1,str2)<<endl;
}
}