分网线(二分法)

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a “star” topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.

To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.

The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.

You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.
Input
The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.
Output
Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.

If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number “0.00” (without quotes).
Sample Input
4 11
8.02
7.43
4.57
5.39
Sample Output
2.00
拿题思想:这就是一个老师讲的二分算法的典型列题,题意:有n条网线,长度给了出来,现在要把他们截成k段,并且每一段的长度相同,求能截成的最大长度x(注意题中的单位和x的要求);
遇到问题:就是在进行输出时,用这条语句时:cout<<setiosflags(ios::fixed)<<setprecision(2)<<high<<endl;输出的样列结果是2.01,与题意不符,然后将high改为mid样列输出倒是2.00,但wrong answer了,之后才注意到用 printf("%0.2f\n",floor(high*100)/100);这条语句输出floor函数为向下取整函数,single number “0.00” (without quotes).。
最终解题步骤
1)用一个bool类型的函数,用来比较所取得x是否可以截成k段来,可以返回true,否则false;
2)开始用二分法查找x,即提出low=0,high=网线总长,mid=(low+high)/2,然后类推查找下去直到找出最优的x;
3)注意对x的要求,写出符合的输出语句;

#include <iostream>
#include <cstdio>
#include <iomanip>
#include <cmath>
#define m 10005
using namespace std;
int n,k;
double a[m];
bool ks(double x)
{
    int ns=0;
    for(int i=0;i<n;i++)
        {
            ns=ns+(int)(a[i]/x);
        }
    return ns>=k;
}
int main()
{
    while(scanf("%d%d",&n,&k)!=EOF&&n+k)
        {
            double sum=0;
            for(int i=0;i<n;i++)
                {
                    cin>>a[i];
                    sum+=a[i];
                }
            double low=0.0,high=sum,mid=0.0;
            while(high-low>0.001)
                {
                    mid=(high+low)/2;
                    if(ks(mid))
                        low=mid;
                    else high=mid;
                }
            printf("%0.2f\n",floor(high*100)/100);
        }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值