PTA Shuffling Machine python

PTA数据结构能力自测 自测-5 Shuffling Machine

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

输入格式:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

输出格式:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

输入样例:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

输出样例:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

解题思路:

1.本题的大致意思是分别给出次数a和一组数,这组数里的数字表示序列的下标。然后自己创建一个顺序的需要排列的序列,将序列里的元素按照给定的一组数里的数字(也就是下标)放入一个新的序列中。这个新的序列变成下一次需要排列的序列。重复a次。这就是洗牌机的原理。
2.明白本题的意思后剩下的其实就是按照思路写代码就好了。本题其实默认了card列表是54张牌,但我还是写了一个按照具体的长度变化的card,方便debug。

代码如下

import copy
n = int(input())#次数
list1 = list(map(int,input().split()))#顺序
length = len(list1)

#初始化card列表
S = ['S' + str(i) for i in range(1,14)]
H = ['H' + str(i) for i in range(1,14)]
C = ['C' + str(i) for i in range(1,14)]
D = ['D' + str(i) for i in range(1,14)]
J = ['J1','J2']
card = S+H+C+D+J
card = card[:length]
list2 = [None]*length#初始化一个长度与card一致的序列,不然会出现indexError

for i in range(n):
    k = 0
    for j in list1:
        j -= 1
        list2[j] = card[k]
        k += 1
    card = copy.deepcopy(list2)#注意是深度复制,不要浅复制
print(' '.join(list2))

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值