吃奶酪

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
Input
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.
The input ends with a pair of -1’s.
Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.
Sample Input
3 1
1 2 5
10 11 6
12 12 7
-1 -1
Sample Output
37
题意
肥老鼠在一个城市里储存了一些奶酪。城市可以被看作是一个尺寸n的正方形网格:每个网格位置都有标签(p,q),其中0<=p<n和0<=q<n。在每个网格位置,Fatmouse将0到100块奶酪藏在一个洞里。现在他要享受他最喜欢的食物了。

胖鼠从站在位置(0,0)开始。他把奶酪吃掉,然后水平或垂直地跑到另一个地方。问题是,有一只超级猫叫头号杀手坐在它的洞附近,所以每次它都能跑到最多k个地方进入洞里,然后被头号杀手抓住。更糟糕的是,在一个地方吃完奶酪后,肥老鼠会变得更胖。因此,为了获得足够的能量来进行下一次跑步,他必须跑到一个比当前洞里的奶酪块更多的地方。

给定n,k和每个网格位置的奶酪块数,计算肥鼠在无法移动之前可以吃的奶酪的最大数量。

输入

有几个测试用例。每个测试用例包括

包含1到100之间的两个整数的行:n和k

n行,每行有n个数字:第一行包含位置(0,0)(0,1)处的奶酪块数。。。(0,n-1);下一行包含位置(1,0),(1,1)。。。(1,n-1)等等。

输入以一对-1结束。

输出

对于一行中的每个测试用例输出,一个整数表示收集的奶酪块的数量。

样本输入

3 1个

1 2 5个

2011年10月6日

12 12 7年

-1-1个

样本输出

37个
代码

#include<stdio.h>
#include<string.h>
int dis[121][1212],a[121][121];
int bu[4][2]={{0,-1},{0,1},{-1,0},{1,0}};
int n,m;
int qwe(int x,int y)
{
	int i,j,tx,ty,maxx=0;
	if(dis[x][y]!=-1)//省时
	return dis[x][y];
	for(i=0;i<4;i++)//4个方向
	for(j=1;j<=m;j++)//可以一次走1~m步
	{
		tx=x+bu[i][0]*j;
		ty=y+bu[i][1]*j; 
		if(tx<0||tx>=n||ty<0||ty>=n||a[tx][ty]<=a[x][y])
		continue;
		int t;
		t=qwe(tx,ty);
		if(t>maxx)//求最大数量
		  maxx=t;
	}
	dis[x][y]=a[x][y]+maxx;
	return dis[x][y];
}
int main( )
{
	int i,j;
	while(~scanf("%d%d",&n,&m))
	{
		if(n==-1&&m==-1)/结束条件
		break;
		memset(dis,-1,sizeof(dis));
		for(i=0;i<n;i++)//输入地图
		for(j=0;j<n;j++)
		scanf("%d",&a[i][j]);
		int s;
		s=qwe(0,0);//题意从(0,0)开始
		printf("%d\n",s);
	}
	return 0;
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值