W2 - Ananagrams

题目描述

Most crossword puzzle fans are used to anagrams — groups of words with the same letters in different
orders — for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this
attribute, no matter how you rearrange their letters, you cannot form another word. Such words are
called ananagrams, an example is QUIZ.
Obviously such definitions depend on the domain within which we are working; you might think
that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible
domain would be the entire English language, but this could lead to some problems. One could restrict
the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the
same domain) but NOTE is not since it can produce TONE.
Write a program that will read in the dictionary of a restricted domain and determine the relative
ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be
“rearranged” at all. The dictionary will contain no more than 1000 words.

Input

Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any
number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken
across lines. Spaces may appear freely around words, and at least one space separates multiple words
on the same line. Note that words that contain the same letters but of differing case are considered to
be anagrams of each other, thus ‘tIeD’ and ‘EdiT’ are anagrams. The file will be terminated by a line
consisting of a single ‘#’.

Output

Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram
in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always
be at least one relative ananagram.

Sample Input

ladder came tape soon leader acme RIDE lone Dreis peat
ScAlE orb eye Rides dealer NotE derail LaCeS drIed
noel dire Disk mace Rob dries

Sample Output

Disk
NotE
derail
drIed
eye
ladder
soon

分析

我的思路是用一个map容器,把字符串转为小写而且字符间排序作为键值,把出现次数和源字符串组成pair存为值。将map的键值对存入vector容器并按照源字符串排序,遍历vector,若出现次数为1次则输出源字符串。

Code

/*
 * @Description: Ananagrams
 * @version:
 * @Author:
 * @Date: 2021-04-08 09:41:45
 * @LastEditors: Please set LastEditors
 * @LastEditTime: 2021-04-08 11:38:52
 */
// self
#include <iostream>
#include <string>
#include <map>
#include <algorithm>
#include<vector>
using namespace std;
map<string, pair<int, string>> lowercase;
string toLower(string str)
{
	for (int i = 0; i < str.length(); i++)
		str[i] = tolower(str[i]);
	return str;
}
bool cmp(pair<string, pair<int, string>> a, pair<string, pair<int, string>> b)
{
	return a.second.second < b.second.second;
}
int main(void)
{
	ios::sync_with_stdio(false);
	cin.tie(0);
	string str;
	while (cin >> str && str[0] != '#')
	{
		string raw = str;
		str = toLower(str);
		sort(str.begin(), str.end());
		if (lowercase.find(str) == lowercase.end())
			lowercase[str] = make_pair(1, raw);
		else
			lowercase[str].first++;
	}
	vector<pair<string, pair<int, string>>> temp(lowercase.begin(), lowercase.end());
	sort(temp.begin(), temp.end(), cmp);
	for (int i=0;i<temp.size();i++)
	{
		if(temp[i].second.first == 1)
		cout << temp[i].second.second << endl;
	}
	// system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

jian圣楠

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值