HDU - 1002 A + B Problem II

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
解题思路:
就是模拟加法

c[j]=a[len1]+b[len2]-'0'+k;
 if(c[j]>'9') 
 {
     c[j]=c[j]-10;
     k=1;
 }

注意:逆序输出时要注意过滤前导零。

#include<stdio.h>
#include<string.h>
char a[10000],b[10000];
char c[1000001];
int main()
{
    int n=0,i=0;
    scanf("%d",&n);
    for(i=1;i<=n;i++)
	{
        scanf("%s %s",a,b);
        printf("Case %d:\n%s + %s = ",i,a,b);
        int len1,len2,j=0,k=0;
    len1=strlen(a)-1; len2=strlen(b)-1;
    for(j=0;len1>=0||len2>=0;j++,len1--,len2--)
	{
        if(len1>=0&&len2>=0) 
			c[j]=a[len1]+b[len2]-'0'+k;
        if(len1>=0&&len2<0) 
			c[j]=a[len1]+k;
        if(len1<0&&len2>=0) 
			c[j]=b[len2]+k;
        k=0;
        if(c[j]>'9') 
		{
            c[j]=c[j]-10;
            k=1;
        }
    }
    if(k) 
	printf("1");
    while(j--)
	{
        printf("%c",c[j]);
    }
        if(i<n) 
		printf("\n\n");
        else 
		printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

沐雨风栉

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值