杭电1002大数加法

原题:

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
个人求解:(双链表)
#include<iostream>
#include<string>
using namespace std;
struct node
{
   int data;
   node*next;
   node*prior;
};
int main()
{  
    node*head1,*head2,*head3,*s,*p,*q,*l;
 head1=new node;
 head2=new node;
 head3=new node;
    head1->next=head2->next=head3->next=NULL;
    head1->prior=head2->prior=head3->prior=NULL;
    string a,b;
    int t,i,j,sum,carry=0;
    cin>>t;
    for(i=0;i<t;i++)
    {
       cin>>a>>b;
       p=head1;
       for(j=a.size()-1;j>=0;j--)
       {
          s=new node;
          s->data=a[j]-'0';
          p->next=s;
          s->prior=p;
          p=s;
       }
       p->next=NULL;
       p=head2;
       for(j=b.size()-1;j>=0;j--)
       {
           s=new node;
           s->data=b[j]-'0';
           p->next=s;
           s->prior=p;
           p=s;
       }
       p->next=NULL;
       s=head1->next;
       p=head2->next;
       q=head3;
       while(s!=NULL&&p!=NULL)
       {
       sum=(s->data+p->data+carry)%10;
       carry=(s->data+p->data+carry)/10;
       l=new node;
       l->data=sum;
       l->prior=q;
       q->next=l;
       q=l;
       s=s->next;
       p=p->next;
       }
       if(s!=NULL)
       p=s;
       while(p!=NULL)
       {
       sum=(p->data+carry)%10;
       carry=(p->data+carry)/10;
       l=new node;
       l->data=sum;
       q->next=l;
       l->prior=q;
       q=l;
       }
       if(carry!=0)
       {
       l=new node;
       l->data=carry;
       q->next=l;
       l->prior=q;
       l->next=NULL;
       }
    cout<<"Case "<<i+1<<":"<<endl;
    cout<<a<<" + "<<b<<" = ";
    while(l!=head3)
    {
        cout<<l->data;
        l=l->prior;
    }
    if(i!=t-1)
    cout<<endl<<endl;
    else cout<<endl;
  }
    system("pause");
    return 0;
}
但出现Memory exceeded错误;
改进:
#include<iostream>
#include<string>
using namespace std;
int main()
{
    int t,carry,size,tsize,size1,size2,*c,i,j;
    char a[1000],b[1000];
    cin>>t;
    for(i=1;i<=t;i++)
    {
       cin>>a>>b;
       carry=0;
       size1=strlen(a);
       size2=strlen(b);
       if(size1>size2)
         size=size1;
         else
         size=size2;
       tsize=size;
       c=new int[size];
       size1--;
       size2--;
       size--;
       while(size1>=0&&size2>=0)
       {
           c[size]=(a[size1]-'0'+b[size2]-'0'+carry)%10;
           carry=(a[size1]-'0'+b[size2]-'0'+carry)/10;
           size1--;
           size2--;
           size--;
       }
       while(size1>=0)
       {
          c[size]=(a[size1]-'0'+carry)%10;
          carry=(a[size1]-'0'+carry)/10;
          size--;
          size1--;
       }
       while(size2>=0)
       {
          c[size]=(b[size2]-'0'+carry)%10;
          carry=(b[size2]-'0'+carry)/10;
          size--;
          size2--;
       }
       cout<<"Case "<<i<<":"<<endl;
    cout<<a<<" + "<<b<<" = ";
       if(carry!=0)cout<<carry;
       for(j=0;j<tsize;j++)
       {
         cout<<c[j];
       }
       if(i!=t)cout<<endl<<endl;
       else cout<<endl;
    }
    return 0;
}

一种更节省内存的解法:
#include <iostream>
#include <string>
using namespace std;
string Addition(string one, string two);
int main()
{
    int n, i;
    string first, second;
    cin >> n;
    for(i=0;i<n;i++)
    {
        cin >> first >> second;
        cout << "Case " << i+1 << ":" << endl
            << first << " + " << second
            << " = " << Addition(first, second) << endl;
        if(i != n-1)
            cout << endl;
    }
    return 0;
}
string Addition(string one, string two)
{
    int j, max;
    //分别表示第一,二个字符串的长度
    int flen, slen;
    string sum;
    flen = one.size();
    slen = two.size();
    if(flen >= slen)
    {
        sum = one;
        for(j=0;j<slen;j++)
            sum[flen-j-1] = sum[flen-j-1] + two[slen-j-1] - '0';
        max = flen;
    }
    else
    {
        sum = two;
        for(j=0;j<flen;j++)
            sum[slen-j-1] = sum[slen-j-1] + one[flen-j-1] - '0';
        max = slen;
    }
    //如果第j位的数大于9,则将其减10,并向上一位进一
    for(j=max-1;j>=1;j--)
    {
        if(sum[j] > '9')
        {
            sum[j] -= 10;
            sum[j-1]++;
        }
    }
    if(sum[0] > '9')
    {
        sum[0] -= 10;
        sum = "1" + sum;
    }
    return sum;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Go语言(也称为Golang)是由Google开发的一种静态强类型、编译型的编程语言。它旨在成为一门简单、高效、安全和并发的编程语言,特别适用于构建高性能的服务器和分布式系统。以下是Go语言的一些主要特点和优势: 简洁性:Go语言的语法简单直观,易于学习和使用。它避免了复杂的语法特性,如继承、重载等,转而采用组合和接口来实现代码的复用和扩展。 高性能:Go语言具有出色的性能,可以媲美C和C++。它使用静态类型系统和编译型语言的优势,能够生成高效的机器码。 并发性:Go语言内置了对并发的支持,通过轻量级的goroutine和channel机制,可以轻松实现并发编程。这使得Go语言在构建高性能的服务器和分布式系统时具有天然的优势。 安全性:Go语言具有强大的类型系统和内存管理机制,能够减少运行时错误和内存泄漏等问题。它还支持编译时检查,可以在编译阶段就发现潜在的问题。 标准库:Go语言的标准库非常丰富,包含了大量的实用功能和工具,如网络编程、文件操作、加密解密等。这使得开发者可以更加专注于业务逻辑的实现,而无需花费太多时间在底层功能的实现上。 跨平台:Go语言支持多种操作系统和平台,包括Windows、Linux、macOS等。它使用统一的构建系统(如Go Modules),可以轻松地跨平台编译和运行代码。 开源和社区支持:Go语言是开源的,具有庞大的社区支持和丰富的资源。开发者可以通过社区获取帮助、分享经验和学习资料。 总之,Go语言是一种简单、高效、安全、并发的编程语言,特别适用于构建高性能的服务器和分布式系统。如果你正在寻找一种易于学习和使用的编程语言,并且需要处理大量的并发请求和数据,那么Go语言可能是一个不错的选择。
Go语言(也称为Golang)是由Google开发的一种静态强类型、编译型的编程语言。它旨在成为一门简单、高效、安全和并发的编程语言,特别适用于构建高性能的服务器和分布式系统。以下是Go语言的一些主要特点和优势: 简洁性:Go语言的语法简单直观,易于学习和使用。它避免了复杂的语法特性,如继承、重载等,转而采用组合和接口来实现代码的复用和扩展。 高性能:Go语言具有出色的性能,可以媲美C和C++。它使用静态类型系统和编译型语言的优势,能够生成高效的机器码。 并发性:Go语言内置了对并发的支持,通过轻量级的goroutine和channel机制,可以轻松实现并发编程。这使得Go语言在构建高性能的服务器和分布式系统时具有天然的优势。 安全性:Go语言具有强大的类型系统和内存管理机制,能够减少运行时错误和内存泄漏等问题。它还支持编译时检查,可以在编译阶段就发现潜在的问题。 标准库:Go语言的标准库非常丰富,包含了大量的实用功能和工具,如网络编程、文件操作、加密解密等。这使得开发者可以更加专注于业务逻辑的实现,而无需花费太多时间在底层功能的实现上。 跨平台:Go语言支持多种操作系统和平台,包括Windows、Linux、macOS等。它使用统一的构建系统(如Go Modules),可以轻松地跨平台编译和运行代码。 开源和社区支持:Go语言是开源的,具有庞大的社区支持和丰富的资源。开发者可以通过社区获取帮助、分享经验和学习资料。 总之,Go语言是一种简单、高效、安全、并发的编程语言,特别适用于构建高性能的服务器和分布式系统。如果你正在寻找一种易于学习和使用的编程语言,并且需要处理大量的并发请求和数据,那么Go语言可能是一个不错的选择。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值