POJ - 2531 Network Saboteur

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts.
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks.
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him.
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).
Input
The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000).
Output file must contain a single integer – the maximum traffic between the subnetworks.
Output
Output must contain a single integer – the maximum traffic between the subnetworks.
Sample Input
3
0 50 30
50 0 40
30 40 0
Sample Output
90

这题的题意比较难看懂,将图中的n个点分为两个部分,求出一边所有点到另一边所有点的距离最大值是什么值
只需要枚举所有状况,因为n最大只有20,所以也不用担心超时

首先我们将所有的点标记为0(即所有点放在一个集合里),然后每取出一个点标记为1(即将该点放在另一个集合里),直接暴力深搜,如果取出这个点,我们就遍历原来的集合,更新sum的数据,如果在同一个集合减去他们两个之间的权值,对于不在一个集合里的点,我们加上他们之间的权值。最后的结果为最大值。

#include<stdio.h>
#include<string.h>

int n,k;
int a[32][32],b[32];
void dfs(int s,int sum)
{
     b[s]=1;//利用标记数组划分出两个集合
    for(int i=1;i<=n;i++)
    {
        if(b[i])//如果当前的数在集合中减去当前数到该集合的距离
            sum-=a[s][i];
        else
            sum+=a[s][i];//否则加上
    }
    int max=k;
	if(max<sum)
    	k=sum;
    for(int i=s+1;i<=n;i++)//枚举下一个点再加入集合
    {
        b[i]=1;
        dfs(i,sum);
        b[i]=0;
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        k=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&a[i][j]);
            }
        }
        memset(b,0,sizeof(b));
        dfs(1,0);
    printf("%d\n",k);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

沐雨风栉

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值