4.计蒜客ACM题库.A1947 An Olympian Math Problem

10 篇文章 0 订阅
10 篇文章 0 订阅

计蒜客ACM题库.A1947 An Olympian Math Problem

Alice, a student of grade 6, is thinking about an Olympian Math problem, but she feels so despair that she cries. And her classmate, Bob, has no idea about the problem. Thus he wants you to help him. The problem is:

We denote k!:

k! = 1×2×⋯×(k-1)×k

We denote S:

S=1×1!+2×2!+⋯+(n - 1) × (n-1)!

Then S module n is ____________

You are given an integer nn.

You have to calculate S modulo nn.

Input
The first line contains an integer T(T≤1000), denoting the number of test cases.

For each test case, there is a line which has an integer n.

It is guaranteed that 2≤n≤10^18
.

Output
For each test case, print an integer S modulo n.

Hint
The first test is: S=1×1!=1, and 1 modulo 2 is 1.

The second test is: S=1×1!+2×2!=5 , and 5 modulo 3 is 2.

样例输入复制
2
2
3
样例输出复制
1
2
题目来源
ACM-ICPC 2018 南京赛区网络预赛

解:

#include<iostream>
using namespace std;
int main(){
    int n;
    cin>>n;
    long long int a;//注意a范围
    while(n--){
        cin>>a;
        cout<<a-1<<"\n";
    }
}

解决方法:通过以下代码可以发现前几个答案规律

#include<iostream>
using namespace std;
int factorial(int a){
    int ans=1,i;
    for(i=1;i<=a;i++){
        ans=ans*i;
    }
    return ans;
}
int main(){
    int n;
    cin>>n;
    int a[n], i, S, count;
    for(i=0;i<n;i++){
        cin>>a[i];
    }
    i = 0;
    for(i=0;i<n;i++){
        S = 0;
        for(count=1;count<a[i];count++){
            S=S+count*factorial(count);
        }
        S=S%a[i];
        cout<<S<<"\n";
    }
}

结语:万事尽头 终将如意 但行好事 莫问前程

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值