ACM-ICPC 2018 南京赛区网络预赛 A(An Olympian Math Problem)

Alice, a student of grade 66, is thinking about an Olympian Math problem, but she feels so despair that she cries. And her classmate, Bob, has no idea about the problem. Thus he wants you to help him. The problem is:

We denote k!:

k! =1×2×⋯×(k−1)×k

We denote S:

S =1×1!+2×2!+⋯+ (n−1)×(n−1)!

Then S module n is ____________

You are given an integer nn.

You have to calculate S modulo n.

Input
The first line contains an integer T(T≤1000), denoting the number of test cases.

For each test case, there is a line which has an integer n.

It is guaranteed that 10^{18}2≤n≤10 ^18
 .

Output
For each test case, print an integer SS modulo nn.

Hint
The first test is: S = 1\times 1!= 1S=1×1!=1, and 1 modulo 2 is 1.

The second test is: S = 1\times 1!+2 \times 2!= 5S=1×1!+2×2!=5 , and 5 modulo 3 is 2.

样例输入 
2
2
3
样例输出 
1
2

题意:给出n,S=1+2*2!+3*3!+...(n-1)*(n-1)!     求S%n

思路:输出n-1

推导来自:https://zhidao.baidu.com/question/364445479.html

1x1!+2x2!+3x3!+4x4!+.....+nxn!=(n+1)!-1
证明:
左边=(2-1)x1!+2x2!+3x3!+4x4!+.....+nxn!
=2!-1+2x2!+3x3!+4x4!+.....+nxn!
=(1+2)x2!-1+3x3!+4x4!+.....+nxn!
=3!-1+3x3!+4x4!+.....+nxn!
=(1+3)x3!-1+4x4!+.....+nxn!
=4!-1+5x5!+.....+nxn!
..........
=(n+1)!-1
所以:S=1×1!+2×2!+3×3!+……+n×n!=(n+1)!-1

代码:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const ll MAXN=1e5+5;

ll n;

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lld",&n);
        printf("%lld\n",n-1);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值