8.计蒜客ACM题库.A2019 Save the Room

10 篇文章 0 订阅
10 篇文章 0 订阅

8.计蒜客ACM题库.A2019 Save the Room

Bob is a sorcerer. He lives in a cuboid room which has a length of A, a width of B and a height of C, so we represent it as A * B * C. One day, he finds that his room is filled with unknown dark energy. Bob wants to neutralize all the dark energy in his room with his light magic. He can summon a 1 * 1 * 2 cuboid at a time to neutralize dark energy. But the cuboid must be totally in dark energy to take effect. Can you foresee whether Bob can save his room or not?

Input
Input has T test cases.T≤100

For each line, there are three integers A, B, C.

1≤A,B,C≤100

Output
For each test case, if Bob can save his room, print"Yes", otherwise print"No".

样例输入复制
1 1 2
1 1 4
1 1 1
样例输出复制
Yes
Yes
No

解:

#include<iostream>
using namespace std;
int main(){
	int l,w,h;
	while(scanf("%d %d %d",&l,&w,&h)!=EOF){//多实例输入
		if(l%2==0||h%2==0||w%2==0){//这个没有固定长方形空间是横竖还是平放
			cout<<"Yes"<<'\n';
		}
		else{
			cout<<"No"<<'\n';
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值