华为路由交换由浅入深系列(二):静态路由、浮动路由、默认路由配置以及华为路由协议优先级总结

掌握目标

一、配置设备名称与IP地址:
二、配置静态路由
三、配置浮动路由用于备份
四、配置默认路由
五、了解华为不同路由协议的优先级

拓扑

huawei

一、配置设备名称与IP地址:

R1:
system-view
Enter system view, return user view with Ctrl+Z.
[Huawei]sysname R1
[R1]interface g0/0/1
[R1-GigabitEthernet0/0/1]ip address 202.100.1.1 255.255.255.0
quit
[R1]interface g0/0/2
[R1-GigabitEthernet0/0/2]ip add 202.100.2.1 255.255.255.0
quit
[R1-GigabitEthernet0/0/1]int lo 0 =====创建环回接口
[R1-LoopBack0]ip add 1.1.1.1 255.255.255.255
[R1-LoopBack0]quit

[R1]display current-configuration interface =====显示接口信息
#
interface GigabitEthernet0/0/0
#
interface GigabitEthernet0/0/1
ip address 202.100.1.1 255.255.255.0
#
interface GigabitEthernet0/0/2
ip address 202.100.2.1 255.255.255.0
#
interface NULL0
#
interface LoopBack0
ip address 1.1.1.1 255.255.255.255

R2:
[R2]interface g0/0/1
[R2-GigabitEthernet0/0/1]ip add 202.100.1.2 255.255.255.0
[R2-GigabitEthernet0/0/1]int g0/0/0
[R2-GigabitEthernet0/0/0]ip add 202.100.3.2 255.255.255.0
[R2-GigabitEthernet0/0/0]int lo 0
[R2-LoopBack0]ip ad 2.2.2.2 255.255.255.255
[R2-LoopBack0]quit

R3:
[R3]int g0/0/2
[R3-GigabitEthernet0/0/2]ip add 202.100.2.3 255.255.255.0
[R3-GigabitEthernet0/0/2]int g0/0/0
[R3-GigabitEthernet0/0/0]ip add 202.100.3.3 255.255.255.0
[R3-GigabitEthernet0/0/0]int lo 0
[R3-LoopBack0]ip add 3.3.3.3 255.255.255.255

ping -c 2 202.100.1.2 =====ping两个数据包
PING 202.100.1.2: 56 data bytes, press CTRL_C to break
Reply from 202.100.1.2: bytes=56 Sequence=1 ttl=255 time=10 ms
Reply from 202.100.1.2: bytes=56 Sequence=2 ttl=255 time=1 ms
— 202.100.1.2 ping statistics —
2 packet(s) transmitted
2 packet(s) received
0.00% packet loss
round-trip min/avg/max = 1/5/10 ms

ping -c 2 202.100.2.3
PING 202.100.2.3: 56 data bytes, press CTRL_C to break
Reply from 202.100.2.3: bytes=56 Sequence=1 ttl=255 time=20 ms
Reply from 202.100.2.3: bytes=56 Sequence=2 ttl=255 time=10 ms
— 202.100.2.3 ping statistics —
2 packet(s) transmitted
2 packet(s) received
0.00% packet loss
round-trip min/avg/max = 10/15/20 ms

display ip routing-table ====查看路由表
Route Flags: R – relay, D – download to fib
——————————————————————————
Routing Tables: Public
Destinations : 11 Routes : 11

Destination/Mask Proto Pre Cost Flags NextHop Interface
1.1.1.1/32 Direct 0 0 D 127.0.0.1 LoopBack0
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0
127.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
202.100.1.0/24 Direct 0 0 D 202.100.1.1 GigabitEthernet0

二、配置静态路由

[R1]ip route-static 3.3.3.3 255.255.255.255 202.100.2.3 ===添加静态路由
[R1]ip route-static 202.100.3.0 255.255.255.0 202.100.2.3

[R1]display ip routing-table =====Static代表静态路由,60代表静态路由优先级
Route Flags: R – relay, D – download to fib
——————————————————————————
Routing Tables: Public
Destinations : 13 Routes : 13
Destination/Mask Proto Pre Cost Flags NextHop Interface
1.1.1.1/32 Direct 0 0 D 127.0.0.1 LoopBack0
3.3.3.3/32 Static 60 0 RD 202.100.2.3 GigabitEthernet0
ping -c 1 3.3.3.3
PING 3.3.3.3: 56 data bytes, press CTRL_C to break
Reply from 3.3.3.3: bytes=56 Sequence=1 ttl=255 time=10 ms

ping -c 1 202.100.3.3
PING 202.100.3.3: 56 data bytes, press CTRL_C to break
Reply from 202.100.3.3: bytes=56 Sequence=1 ttl=255 time=10 ms

三、配置浮动路由用于备份

配置备份静态路由,当R1与R3之间链路出现故障时,可走R2。
[R2]ip route-static 3.3.3.3 255.255.255.255 202.100.3.3
[R1]ip route-static 202.100.3.0 24 202.100.1.2 preference 80
[R1]ip route-static 3.3.3.3 32 202.100.1.2 preference 80

[R3]ip route-static 202.100.1.0 255.255.255.0 202.100.3.2

[R1]tracert 202.100.3.3
traceroute to 202.100.3.3(202.100.3.3), max hops: 30 ,packet length: 40,press CTRL_C to break
1 202.100.2.3 10 ms 10 ms 20 ms

[R1]tracert 3.3.3.3
traceroute to 3.3.3.3(3.3.3.3), max hops: 30 ,packet length: 40,press CTRL_C to break
1 202.100.2.3 20 ms 10 ms 20 ms

[R1]int g0/0/2
[R1-GigabitEthernet0/0/2]shutdown

[R1]display ip routing-table
Route Flags: R – relay, D – download to fib
——————————————————————————
Routing Tables: Public
Destinations : 10 Routes : 10
3.3.3.3/32 Static 80 0 RD 202.100.1.2 GigabitEthernet0/0/1
202.100.3.0/24 Static 80 0 RD 202.100.1.2 GigabitEthernet0/0/1

[R1]tracert 3.3.3.3
1 202.100.1.2 20 ms 1 ms 10 ms
2 202.100.3.3 20 ms 10 ms 20 ms

[R1]tracert 202.100.3.3
1 202.100.1.2 1 ms 10 ms 10 ms
2 202.100.3.3 20 ms 20 ms 20 ms

[R1]interface g0/0/2
[R1-GigabitEthernet0/0/2]undo shutdown (注:华为设备中no掉配置命令undo) 此处敲restart也可以
May 12 2014 22:58:05-05:13 R1 %%01IFPDT/4/IF_STATE(l)[6]:Interface GigabitEtherne
t0/0/2 has turned into UP state.

[R2]ip route-static 0.0.0.0 0.0.0.0 202.100.3.3 ====添加默认路由
[R2]ping 202.100.2.1
PING 202.100.2.1: 56 data bytes, press CTRL_C to break
Reply from 202.100.2.1: bytes=56 Sequence=1 ttl=254 time=10 ms
Reply from 202.100.2.1: bytes=56 Sequence=5 ttl=254 time=30 ms

四、配置默认路由

配置备份默认路由,当R2与R3之间链路出现故障时,可走R1。
[R2]ip route-static 0.0.0.0 0.0.0.0 202.100.1.1 preference 80
[R3]ip route-static 0.0.0.0 0.0.0.0 202.100.2.1 preference 80

[R2]int g0/0/0
[R2-GigabitEthernet0/0/0]shut
[R2-GigabitEthernet0/0/0]

[R2]tracert 202.100.2.3
traceroute to 202.100.2.3(202.100.2.3), max hops: 30 ,packet length: 40,press CTRL_C to break
1 202.100.1.1 10 ms 10 ms 10 ms
2 202.100.2.3 20 ms 20 ms 10 ms

五、了解华为不同路由协议的优先级

huawei

如果大家有任何疑问或者文中有错误跟疏忽的地方,欢迎大家留言指出,博主看到后会第一时间修改,谢谢大家的支持,更多技术文章尽在网络之路Blog(其他平台同名),版权归网络之路Blog所有,原创不易,侵权必究,觉得有帮助的,关注、转发、点赞支持下!~。

  • 0
    点赞
  • 10
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值