【POJ】3494 Largest Submatrix of All 1’s

【POJ】3494 Largest Submatrix of All 1’s

Time Limit: 5000MS
Memory Limit: 131072K
Case Time Limit: 2000MS

Description

Given a m-by-n (0,1)-matrix, of all its submatrices of all 1’s which is the largest? By largest we mean that the submatrix has the most elements.

Input

The input contains multiple test cases. Each test case begins with m and n (1 ≤ m, n ≤ 2000) on line. Then come the elements of a (0,1)-matrix in row-major order on m lines each with n numbers. The input ends once EOF is met.

Output

For each test case, output one line containing the number of elements of the largest submatrix of all 1’s. If the given matrix is of all 0’s, output 0.

Sample Input

2 2
0 0
0 0
4 4
0 0 0 0
0 1 1 0
0 1 1 0
0 0 0 0

Sample Output

0
4

翻译

所有1的最大子矩阵

时限: 5000MS
内存限制: 131072K
案件时限: 2000MS

描述

给定一个m × n(0,1)矩阵,所有1的所有子矩阵中哪个最大?通过最大的,我们是指子矩阵拥有最多的元素。

输入

输入包含多个测试用例。每个测试用例始于米和Ñ(1≤米,Ñ上线≤2000)。然后按行优先顺序在每行具有n个数字的m行上出现(0,1)-矩阵的元素。一旦满足EOF,输入即结束。

输出

对于每个测试用例,输出一行,其中包含所有1的最大子矩阵的元素数量。如果给定的矩阵全为0,则输出0。

样本输入

2 2
0 0
0 0
4 4
0 0 0 0
0 1 1 0
0 1 1 0
0 0 0 0

样本输出

0
4

思路

该题为POJ2559的升级版。
每一层计算当前列从下往上连续1的个数,做一次最大面积,比较最大值。

代码

#include<iostream>
#include<cstdio>
#include<stack>
#include<cstring>
using namespace std;
long long a[100010]; 
struct jgt
{
	long long wide,high;//宽,高。 
}; 
stack<jgt> s,k;
int main()
{
	long long n,m,i,j,ans,w,t,sum;
	jgt tem;
	while(cin>>n>>m)
	{
		memset(a,0,sizeof(a));
		for(s=k,a[m+1]=-1,ans=0,i=1;i<=n;i++)
		{
			for(j=1;j<=m;j++) 
			{
				scanf("%lld",&t);
				if(t) a[j]++;
				else a[j]=0;
			}
			for(j=1;j<=m+1;j++)
			{
				for(w=0;!s.empty()&&a[j]<=s.top().high;s.pop())//删除大于当前数的数
				{
				    w+=s.top().wide;//宽度增加 
				    ans=max(w*s.top().high,ans);//求最大面积 
				}
				tem.high=a[j],tem.wide=w+1;
				s.push(tem);
			}
		}
		printf("%lld\n",ans);
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值