Centos8 podman问题

Centos8 podman问题

在centos8中进行安装docker出现冲突问题,于是就对yum进行更新,但是仍然报错,显示得是与podman冲突,版本不对等问题,大致报错如下:
Last metadata expiration check: 0:01:04 ago on Mon 08 Mar 2021 10:53:12 AM EST.
Error:
Problem 1: cannot install the best update candidate for package libidn2-2.2.0-1.el8.x86_64

  • nothing provides libunistring.so.0()(64bit) needed by libidn2-2.3.0-1.el7.x86_64
    Problem 2: package podman-2.2.1-7.module_el8.3.0+699+d61d9c41.x86_64 requires runc >= 1.0.0-57, but none of the providers can be installed

在这里插入图片描述
解决方法如下:yum erase podman buildah
在这里插入图片描述
安装完后再次安装docker-ce就可以了
在这里插入图片描述

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 数字20 设计师:CSDN官方博客 返回首页