poj-2531 Network Saboteur(DFS)

Network Saboteur

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17238 Accepted: 8677
Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts.
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks.
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him.
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).
Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000).
Output file must contain a single integer – the maximum traffic between the subnetworks.
Output

Output must contain a single integer – the maximum traffic between the subnetworks.
Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90

题意:

给定结点之间的权值,要求把结点分成A、B两组,使得∑Cij (i∈A,j∈B)最大。

分析:

首先把所有节点都放在一组,然后采用深度优先搜索的方法,对每一个节点都做判断是否应该移到另一组去,判断的依据是移过去和不移过去哪个得到的和值比较大(这里移去B组后的计算方法就是加上该点和在A组中的所有点的间距,和减去原本就在B组中的所有点的间距),如果移过去变小了,那么则不移过去,并剪掉该条支路。

代码:

#include<iostream>
#include<cmath>
using namespace std;
int maps[25][25];
int vis[25]={0};
int rs,n;
void dfs(int k,int sum)
{
	vis[k]=1;
	int mx=sum;
	//vis为1说明在B组,为0说明在A组
	//刚开始时只有A组
	for(int i=0;i<n;i++){
		if(!vis[i]){
			mx+=maps[k][i];
		}
		else{
			mx-=maps[k][i];
		}
	}
	rs=max(rs,mx);
	if(mx>sum){//剪枝
		for(int j=k+1;j<n;j++){
			dfs(j,mx);
			vis[j]=0;
		}
	}
}
int main()
{
	cin>>n;
	for(int i=0;i<n;i++){
		for(int j=0;j<n;j++){
			cin>>maps[i][j];
		}
	}
	dfs(0,0);
	cout<<rs<<endl;
	return 0;
} 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值