poj-2388 快速排序

Who’s in the Middle

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 54415 Accepted: 31438
Description

FJ is surveying his herd to find the most average cow. He wants to know how much milk this ‘median’ cow gives: half of the cows give as much or more than the median; half give as much or less.

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1…1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
Input

  • Line 1: A single integer N

  • Lines 2…N+1: Each line contains a single integer that is the milk output of one cow.
    Output

  • Line 1: A single integer that is the median milk output.
    Sample Input

5
2
4
1
3
5
Sample Output

3

题意

给定一个奇数N,接下来有N个整数,求这N个整数的中位数。

分析

本题非常简单,可以直接用STL里的sort解决。也可以当作快速排序算法的简单练习题。下面采用快速排序来解决。

代码

#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstdio>
using namespace std;
const int MAXN = 10010;
int data[MAXN];
int partition(int left,int right)
{
	int i=left;
	int temp=data[right];//把尾部的数看成基准数
	for(int j=left;j<right;j++){
		if(data[j]<temp){
			swap(data[j],data[i]);
			i++;
		}
	}
	swap(data[i],data[right]);
	return i;//返回基准数的位置
}
void quicksort(int left,int right)
{
	if(left<right){
		int i=partition(left,right);//划分
		quicksort(left,i-1);//分治,i左边的继续递归划分
		quicksort(i+1,right);//分治,i右边的继续递归划分
	}
}
int main()
{
	int n;
	scanf("%d",&n);
	for(int i=1;i<=n;i++) scanf("%d",&data[i]);
	quicksort(1,n);
	printf("%d\n",data[(n+1)/2]);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值