Moving Tables
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 52571 Accepted Submission(s): 17125
Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.
The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.
For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
Output
The output should contain the minimum time in minutes to complete the moving, one per line.
Sample Input
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50
Sample Output
10
20
30
题意
一家ACM公司要改革,需要在房间之间移动桌子,可是走廊太狭窄,每次只能移动一张桌子,每10分钟内,同一段走廊只能移动一张桌子。经理列出了可行和不可行的情况,不可行也就是占用同一段走廊的情况,如上表。
现在给你N行,每行代表一张桌子的移动路线(从room s到room t),问至少需要多少分钟可以完成所有桌子的移动。
分析
该楼有400个房间,每两个房间共享一条走廊,共200条走廊。通过分析可以知道,要求出最少完成时间,我们只需要看被走重复次数最多的走廊即可。用它的次数乘以10就可以得出答案。比如测试用例3,30号房间到50号房间这段走廊被占用了3次,所以需要30分钟。
代码
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int MAXN = 201;
int crd[MAXN];//一共400间房,共200条走廊
int main()
{
//freopen("data.txt","r",stdin);
int t;
scanf("%d",&t);
while(t--){
memset(crd,0,sizeof(crd));
int ans=0,n;
scanf("%d",&n);
int from,to;
for(int i=0;i<n;i++){
scanf("%d %d",&from,&to);
//小房间号在前
if(from>to){
int t=from;
from=to;
to=t;
}
//算出房间号对应的走廊编号
from=(from+1)/2;
to=(to+1)/2;
for(int i=from;i<=to;i++){
crd[i]++;
//ans每次都选重复走次数最多的走廊
ans=max(crd[i],ans);
}
}
printf("%d\n",ans*10);
}
return 0;
}