AcWing 4789. 前缀和序列

在这里插入图片描述原题连接:https://www.acwing.com/problem/content/4792/

输入样例:
6
6 4 2 7 2 7
3
2 3 6
1 3 4
1 1 6

输出样例:
24
9
28

#include <iostream>
#include <algorithm>
using namespace std;

typedef long long ll;

const int maxn = 1e5+10;

ll x[maxn],y[maxn];

int main()
{
	int n; scanf("%d",&n);
	
	for(int i=1;i<=n;i++)
	{
		scanf("%lld",&x[i]);
		
		y[i] = x[i];	
	}
	
	sort(y+1,y+1+n);
	
	for(int i=1;i<=n;i++) //前缀和处理
	{
		x[i]+=x[i-1];
		y[i]+=y[i-1];	
	}
	
	int m; scanf("%d",&m);
	
	while(m--)
	{
		int k,l,r; scanf("%d %d %d",&k,&l,&r);
		
		if(k == 1)
			cout<<x[r]-x[l-1]<<endl;
		else
			cout<<y[r]-y[l-1]<<endl;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

像linux的企鹅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值