Description
建立字符串的定长存储结构,输入一个字符串,求长度并输出。
Input
输入一个字符串。
Output
输出长度。
Sample Input
Hello world!
Sample Output
12
//求串长
#include <bits/stdc++.h>
using namespace std;
// 函数结果状态代码
#define TRUE 1
#define FALSE 0
#define OK 1
#define ERROR 0
#define INFEASIBLE -1
// #define OVERFLOW -2 因为在math.h中已定义OVERFLOW的值为3,故去掉此行
typedef int Status; // Status是函数的类型,其值是函数结果状态代码,如OK等
typedef int Boolean; // Boolean是布尔类型,其值是TRUE或FALSE
// c4-1.h 串的定长顺序存储表示
#define MAXSTRLEN 255 // 用户可在255以内定义最大串长(1个字节)
typedef char SString[MAXSTRLEN+1]; // 0号单元存放串的长度
// bo4-1.cpp 串采用定长顺序存储结构(由c4-1.h定义)的基本操作(14个)
// SString是数组,故不需引用类型。此基本操作包括算法4.2,4.3,4.5
Status StrAssign(SString T,char *chars)
{ // 生成一个其值等于chars的串T
int i;
if(strlen(chars)>MAXSTRLEN)
return ERROR;
else
{
T[0]=strlen(chars);
for(i=1;i<=T[0];i++)
T[i]=*(chars+i-1);
return OK;
}
}
int main()
{
SString S;
char s[300];
gets(s);
StrAssign(S,s);
printf("%d",S[0]);
}