PAT A1035 Password (20 分)

75 篇文章 0 订阅

PAT A1035 Password (20 分)

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:
For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:
3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa
Sample Output 1:
2
Team000002 RLsp%dfa
Team000001 R@spodfa
Sample Input 2:
1
team110 abcdefg332
Sample Output 2:
There is 1 account and no account is modified
Sample Input 3:
2
team110 abcdefg222
team220 abcdefg333
Sample Output 3:
There are 2 accounts and no account is modified

以下是AC的代码:

#include<cstdio>
#include<cstring>
#define lens 15
#define maxn 1010
struct student{
	char id[lens];
	char password[lens];
	bool change;
}stu[maxn];
student modifi(student a);
int count=0;
int main(void){
	int total;
	scanf("%d",&total);
	for(int i=0;i<total;i++){
		scanf("%s %s",&stu[i].id,&stu[i].password);
		stu[i].change=false;//初始化默认没有修饰过; 
		stu[i]=modifi(stu[i]);
	}
	if(count==0){
		if(total==1)printf("There is 1 account ");
		else printf("There are %d accounts ",total);
		printf("and no account is modified");
	}else{
		printf("%d",count);
		for(int i=0;i<total;i++){
			if(stu[i].change) printf("\n%s %s",stu[i].id,stu[i].password);
		}
	}
	return 0;
} 
student modifi(student a){
	int len=strlen(a.password);
	
	for(int i=0;i<len;i++){
		switch(a.password[i]){
			case '1': a.password[i]='@';a.change=true;break;
			case '0': a.password[i]='%';a.change=true;break;
			case 'l': a.password[i]='L';a.change=true;break;
			case 'O': a.password[i]='o';a.change=true;break;
		}
	}
	if(a.change)count++;
	return a;
}

思路:
把每个学生看成一个含有 id,password 和 change(表示是否修改过密码的bool变量)组成的整体,用结构体封装,建一个数组存放所有的学生。
然后把每个学生信息扫描到数组里,同时就用一个函数modifi来修改扫入的学生的密码,并且同时处理密码的转换问题,函数中如果发生了改动,就让在main函数意外的 count 加1,然后返回修改好的结点。
最后先看count是否为0分别输出。
这里有个可以改进的地方,函数里面可以直接引用原结点,可以直接对原结点进行改动,不用再去赋值。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值