PAT 1035 Password(20分)

原题链接:PAT 1035 Password(20分)

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:
For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

题目大意:

由于密码中有一些符号容易搞混(例如1和l),现在需要对一些用户的密码进行修改。给出了修改的规则,要求最后返回修改过的账号数,以及对应的账号和密码。

方法一:字符串

思路:

按照题目说的模拟即可,需要注意的就是当没有账户进行过修改,以及账户数只有1时,需要特殊的处理

C++ 代码:

// pat 1035 
#include <iostream>
#include <cstring>
using namespace std;

const int maxn = 1010;

int n, m = 0; // n输入用户数 m发生过修改的用户数 
string id[maxn], pwd[maxn];	// 分别存储经过改变的账户和密码 

string change(string str){
	string ans;
	
	for(auto c : str){
		if(c == '1') ans += '@';
		else if(c == '0') ans += '%';
		else if(c == 'l') ans +='L';
        else if(c == 'O') ans +='o';
        else ans += c;
	}
	
	return ans;
}

int main(){
	cin >> n;
	for(int i = 0; i < n; i++ ){
		string cur_id, cur_pwd;
		cin >> cur_id >> cur_pwd;
		
		// 对密码进行变换 
		string new_pwd = change(cur_pwd);
		
		// 如果密码发生过改变 
		if(new_pwd != cur_pwd){
			id[m] = cur_id;
			pwd[m] = new_pwd;
			m++; 
		}  
	}
	
	if(!m){
        if(n == 1)
			puts("There is 1 account and no account is modified");
        else
			cout << "There are " << n << " accounts and no account is modified" << endl;
    }
    else{
        cout << m << endl;
        for(int i = 0; i < m; i ++ )
			cout << id[i] << ' ' <<pwd[i] << endl; 
    }
	
	return 0;
} 

复杂度分析:

  • 时间复杂度;O(n),密码长度不超过十,n个账号的密码都遍历过去一次
  • 空间复杂度:O(1),输出不考虑在内
  • 8
    点赞
  • 26
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值