PAT B1020 月饼 (25 分)/A 1070 Mooncake (25 分)

75 篇文章 0 订阅

PAT B1020 月饼 (25 分)/A1070 Mooncake (25 分)

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region’s culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:
3 200
180 150 100
7.5 7.2 4.5
Sample Output:
9.45
PAT B1020 月饼 (25 分) 中文题目:
月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。

输入格式:
每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N 表示月饼的种类数、以及不超过 500(以万吨为单位)的正整数 D 表示市场最大需求量。随后一行给出 N 个正数表示每种月饼的库存量(以万吨为单位);最后一行给出 N 个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式:
对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。

输入样例:
3 20
18 15 10
75 72 45
输出样例:
94.50

以下是AC的代码:

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=1100;
struct mooncake{
	double sto,tprice,pprice;
}mcake[maxn];
bool cmp(mooncake a,mooncake b){
	return a.pprice>b.pprice;
}
int main(void){
	int total,i;
	double sum;
	scanf("%d%lf",&total,&sum);
	for(i=0;i<total;i++){
		scanf("%lf",&(mcake[i].sto));
	}
	for(i=0;i<total;i++){
		scanf("%lf",&(mcake[i].tprice));
		mcake[i].pprice=mcake[i].tprice/mcake[i].sto;
	}
	sort(mcake,mcake+total,cmp);
	
	double profit=0.0,weight=0.0;
	for(i=0;weight<=sum&&i<total;i++){//考虑所有库存小于市场需求量的情况; 
		weight+=mcake[i].sto;
		profit+=mcake[i].tprice;
	}
	if(weight>sum){
		profit-=mcake[i-1].pprice*(weight-sum);
	}
	printf("%.2f",profit);
	return 0;
}

思路:
这道题是算法笔记上贪心入门的介绍题。
要得到最大利润,需要总是先卖单价贵的月饼,需要用贪心的思路,将月饼按照单价排序,从上到下枚举贵的月饼,直到市场需求被满足。我这里先保证超出市场需求,然后将超出的部分价格减去。
这里需要注意的是,题目中只说了价格和库存是正数,没有说是正整数,所以需要用double 来存储和计算。

Visual Studio 2010主要用于编写Windows应用程序、Web应用以及游戏等软件,并不是一个图形设计工具,它本身并不支持直接创建月饼形状的代码。如果你想在程序中生成类似月饼的图形,通常需要通过图形库,如.NET Framework的System.Drawing命名空间下的Graphics类,配合特定的位图图像(Bitmap)或者是使用第三方控件来绘制。 例如,你可以使用GDI+ (Graphics Device Interface+) 库来绘制自定义形状,包括月饼。但这涉及到复杂的绘图算法和可能需要一些图形设计知识。下面是一个简化的示例,展示如何使用基本的矩形和圆形来模拟月饼: ```csharp using System; using System.Drawing; namespace MooncakeDrawing { class Program { static void Main() { // 创建画布 Bitmap moonCake = new Bitmap(300, 200); Graphics g = Graphics.FromImage(moonCake); // 绘制月饼形状 Brush fillBrush = new SolidBrush(Color.DarkGoldenrod); // 月饼填充颜色 Pen outlinePen = new Pen(Color.Black, 2); // 月饼边框 // 圆形部 g.FillEllipse(fillBrush, 50, 70, 100, 80); g.DrawEllipse(outlinePen, 50, 70, 100, 80); // 环形部 g.FillRectangle(fillBrush, 90, 50, 120, 120); g.DrawRectangle(outlinePen, 90, 50, 120, 120); g.DrawLine(outlinePen, 65, 95, 135, 95); // 连接两个部的线 // 显示图片 moonCake.Save("MoonCake.png"); // 保存到文件 g.Dispose(); } } } ``` 这只是一个非常基础的示例,实际效果可能不会很像月饼,如果要得到更精确的设计,可能需要专业的图形编辑软件先制作好月饼图案,然后导入到程序中作为背景或者资源。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值