数据结构——括号匹配问题(顺序栈与链栈实现)

题目描述

判断仅由小括号组成的字符串是否满足括号匹配规则

输入格式

输入包括多行,每行一个仅有小括号组成的字符串,长度不超过100

输出格式

输出包括多行,如果对应的输入括号匹配,输出YES,否则输出NO

输入样例

()()()
((()))
())(
((()

输出样例

YES
YES
NO
NO
这个题实际上很简单的,主要是想复习一下顺序栈和链栈的实现。

顺序栈实现

#include <bits/stdc++.h>
using namespace std;
typedef struct SqStack
{
    char *base;
    char top;
    int stacksize;
} SqStack;
void InitStack(SqStack &S)
{
    S.base = (char *)malloc(sizeof(S.stacksize));
    S.top = -1;
}
bool push(SqStack &S, char item)
{
	//栈满,入栈失败。这里可以设置扩容的操作realloc()
    if (S.top == S.stacksize)
    {
        return false;
    }
    S.base[++S.top] = item;
    return true;
}
char pop(SqStack &S)
{
    if (S.top != -1)
    {
        // S.top--;
        return S.base[S.top--];
    }
}
bool block_match(SqStack &S, string str)
{
    for (int i = 0; i < str.length(); i++)
    {
        if (str[i] == '(')
        {
            push(S, str[i]);
        }
        else
        {
            if (S.top == -1 || !pop(S) == '(')
            {
                return false;
            }
        }
    }
    //判断最后是否有括号剩余
    if (S.top == -1)
        return true;
    else
        return false;
}
int main()
{
    string items;
    while (cin >> items)
    {
        SqStack stack;
        stack.stacksize = 100;
        InitStack(stack);
        if (block_match(stack, items))
        {
            printf("YES\n");
        }
        else
            printf("NO\n");
    }
}

链栈实现

#include <bits/stdc++.h>
using namespace std;
#define ElemType char
typedef struct SNode
{
    ElemType data;
    SNode *next;
} SNode, *LinkedStack;
void InitStack(LinkedStack &S)
{
    S = (LinkedStack)malloc(sizeof(SNode));
    S->next = nullptr;
}
void push(LinkedStack &S, ElemType item)
{
    SNode *s;
    s = (SNode *)malloc(sizeof(SNode));
    //头插法
    s->data = item;
    s->next = S->next;
    S->next = s;
}
void pop(LinkedStack &S)
{
    SNode *s = S->next;
    S->next = s->next;
    free(s);
}
bool block_match(LinkedStack &S, string str)
{
    for (int i = 0; i < str.length(); i++)
    {
        if (str[i] == '(')
            push(S, str[i]);
        else
        {
            if (S->next != nullptr)
            {
                pop(S);
            }
            else
                return false;
        }
    }
    if (S->next == nullptr)
        return true;
    else
        return false;
}
int main()
{
    string items;
    while (cin >> items)
    {
        LinkedStack S;
        InitStack(S);
        if (block_match(S, items))
            printf("YES\n");
        else
            printf("NO\n");
    }
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值