1092. To Buy or Not to Buy (20)

102 篇文章 0 订阅
26 篇文章 0 订阅

1092. To Buy or Not to Buy (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is "Yes", please tell her the number of extra beads she has to buy; or if the answer is "No", please tell her the number of beads missing from the string.

For the sake of simplicity, let's use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

Figure 1

Input Specification:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:

For each test case, print your answer in one line. If the answer is "Yes", then also output the number of extra beads Eva has to buy; or if the answer is "No", then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

Sample Input 1:
ppRYYGrrYBR2258
YrR8RrY
Sample Output 1:
Yes 8
Sample Input 2:
ppRYYGrrYB225
YrR8RrY
Sample Output 1:
No 2
第一串商店的
第二串要买的
问如果买商店的这出串,是否满足要买的颜色和对应的个数:满足,Yes,并给出多买个个数
                                              不满足,No,并给出还差几颗
统计个数的时候是某【颜色需要的个数】和【商店提供的这个颜色个数】取最小

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月19日 08:56答案正确201092C++ (g++ 4.7.2)1436datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确11806/6
1答案正确13086/6
2答案正确11806/6
3答案正确13081/1
4答案正确14361/1

#include<iostream> 
#include<string>  
using namespace std; 
void countnum(int *c, string a)
{
  int index = 0; 
  while (a[index]!='\0')
  {
    if (isdigit(a[index])) 
      c[a[index] - '0']++; 
    else if (isupper(a[index])) 
      c[a[index] - 'A' + 36]++; 
    else c[a[index] - 'a' + 10]++; 
    index++;
  }
}
int main()
{
  string shop, eva; 
  int count[2][63] = {0};
  getline(cin, shop);
  getline(cin, eva);
  countnum(count[0],eva);  
  countnum(count[1],shop);
  int goal = 0;
  int index = 0;
  while (index < 63)
  {
    if (count[0][index] != 0 )
      goal += count[0][index] <= count[1][index] ? count[0][index] : count[1][index];
    index++;
  } 
  if (goal < eva.size()) 
    cout << "No " << eva.size() - goal << endl; 
  else 
    cout << "Yes " << shop.size() - goal << endl; 
  system("pause");
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值