1055 The World‘s Richest (25 分) java 题解

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤105) - the total number of people, and K (≤103) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−106,106]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [AminAmax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the Mrichest people with their ages in the range [AminAmax]. Each person's information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

题目大意:

对一批数据进行排序,并输出在某些查询情况(对年龄限制)下的排序。

解题思路:

先读入数据并封装到类装入数组,可以先按年龄先总体排序,后面查询时一旦超出限制范围最大值就break,做一些小的剪枝。查询时,要依次比较年龄,并将符合条件的拼接至string,当没有符合值时,要输出None。时间复杂度为O(m*n)。

java代码:

import java.io.*;
import java.util.*;

public class Main {
	public static void main(String[] args) throws IOException {
		BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
		String[] split = br.readLine().split(" ");
		int n = Integer.parseInt(split[0]);
		int m = Integer.parseInt(split[1]);
		List<Student1055> list = new ArrayList<Student1055>();
		for(int i = 0; i < n;i++) {
			split = br.readLine().split(" ");
			String name = split[0];
			int age = Integer.parseInt(split[1]);
			int num = Integer.parseInt(split[2]);
			list.add(new Student1055(name, age, num));
		}
		Collections.sort(list,new Comparator<Student1055>() {
			@Override
			public int compare(Student1055 o1, Student1055 o2) {
				return o1.age - o2.age;
			}
		});
		StringBuilder builder = new StringBuilder();
		for(int i = 1; i <= m;i++) {
			List<Student1055> list1 = new ArrayList<Student1055>();
			split = br.readLine().split(" ");
			int rage = Integer.parseInt(split[0]);
			int min = Integer.parseInt(split[1]);
			int max = Integer.parseInt(split[2]);
			builder.append(String.format("Case #%d:\n", i));
			for(int j = 0; j < list.size();j++) {
				if(list.get(j).age <= max && list.get(j).age >=min) {
					list1.add(list.get(j));
				}else if(list.get(j).age > max) {
					break;
				}
			}
			Collections.sort(list1);
			int k = 0;
			while(k < list1.size() && k < rage) {
				builder.append(list1.get(k));
				k++;
			}
			if(list1.size() == 0) {
				builder.append("None\n");
			}
		}
		System.out.print(builder.toString().trim());
	}
}
class Student1055 implements Comparable<Student1055>{
	String name;
	int age;
	int num;
	
	public Student1055(String name, int age, int num) {
		this.name = name;
		this.age = age;
		this.num = num;
	}

	@Override
	public String toString() {
		return name + " " + age + " " + num + "\n";
	}

	@Override
	public int compareTo(Student1055 o) {
		if(this.num != o.num) {
			return o.num - this.num;
		}else if(this.age != o.age) {
			return this.age - o.age;
		}else {
			return this.name.compareTo(o.name);
		}
	}
}

PTA提交截图:

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值