1095 Cars on Campus (30 分)

1095 Cars on Campus (30 分)

Zhejiang University has 8 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (≤10^4​​ ), the number of records, and K (≤8×10^​4​​ ) the number of queries. Then N lines follow, each gives a record in the format:

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each in record is paired with the chronologically next record for the same car provided it is an out record. Any in records that are not paired with an out record are ignored, as are out records not paired with an in record. It is guaranteed that at least one car is well paired in the input, and no car is both in and out at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:
For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:
16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00
Sample Output:
1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

题目大意:
给定n条记录,记录信息包含车牌号、时间、进出状态;给定m个时间点,要求输出该时间点校园内车的数量。最后还要输出停留时间最长的车牌号和停留时间。

算法分析:
每条in记录都有和它最接近的out对应,out记录也是如此。所以当有多条同一车牌的in记录时,取最晚的;当有多条同一车牌的out记录时,取最早的

将“in”、“out”状态对应相应的数字

可以将hh:mm:ss的时间转化到秒,便于后面的运算

注意查询时输出的时间节点是递增的,每一次的查询可以在上一次的基础上继续遍历,不然会超时

注意一辆车可能在一天内进出多次,这里我用map<string,int>存储每辆车的停留时间

代码(27分,第四个测试点没过,下次发现问题了再更新吧)

#include<bits/stdc++.h>
using namespace std;
struct node{
	char id[10];
	int time,flag=0;
};
int cmp(struct node a,struct node b){
	if(strcmp(a.id,b.id)!=0)
	return strcmp(a.id,b.id)<0;
	else 
	return a.time<b.time;
}
int cmp2(struct node a,struct node b){
	return a.time<b.time;
}
int main()
{
	int recordNum,queryNum;
	scanf("%d %d",&recordNum,&queryNum);//注意读掉回车,不然对后面字符串的读入有影响 
	vector<node> v(recordNum),valid;
	map<string,int> mapTime;
	char temp[6];
	int h,m,s,time;
	for(int i=0;i<recordNum;i++){
		scanf("%s %d:%d:%d %s",v[i].id,&h,&m,&s,temp);
		time=h*3600+m*60+s;
		v[i].time=time;
		if(strcmp(temp,"in")==0)
		v[i].flag=1;
		else 
		v[i].flag=-1;
	}
	sort(v.begin(),v.end(),cmp);//这里的先id排序,再按时间先后 
	int maxTime=-1;
	for(int i=0;i<recordNum-1;i++){
		if(v[i].flag==1&&v[i+1].flag==-1&&strcmp(v[i].id,v[i+1].id)==0){
			valid.push_back(v[i]);
			valid.push_back(v[i+1]);
			mapTime[v[i].id]+=(v[i+1].time-v[i].time);//注意加括号 
			if(v[i+1].time-v[i].time>maxTime)
			maxTime=v[i+1].time-v[i].time;
		}
	}//选择有效的数据 
	sort(valid.begin(),valid.end(),cmp2);//这里按时间先后排序 
	int cnt[recordNum]={0};//cnt用来存储valid中对应下标元素对应的时刻校园中车的数量 
	for(int i=0;i<valid.size();i++){
		if(i==0)cnt[i]=valid[i].flag;
		else{
			cnt[i]=cnt[i-1]+valid[i].flag;//后面的cnt是在前面cnt的基础上变化 
		}
	}
	int tempIndex=0;
	for(int i=0;i<queryNum;i++){
		scanf("%d:%d:%d",&h,&m,&s);
		time=h*3600+m*60+s;
		int j;
		for(j=tempIndex;j<valid.size();j++){
			if(valid[j].time>time){//后面的时间比较大的话,就将前一个cnt输出 
			printf("%d\n",cnt[j-1]);
			break;
			}
			else if(j==valid.size()-1){//最后一个不管有没有大于都要输出 
			printf("%d\n",cnt[j]);
			}
		}
		tempIndex=j;//因为输入查询时间的是按时间先后的,可以从上一次的index开始遍历 
	}
	for(auto it=mapTime.begin();it!=mapTime.end();it++){//map已经按字典序对key排序完毕了 
		if(it->second==maxTime)printf("%s ",it->first.c_str());
		//这里要将it->first转化为char*才能用printf输出,因为C中没有字符串这种类型 
	}
	printf("%02d:%02d:%02d",maxTime/3600,(maxTime%3600)/60,maxTime%60);
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值