PAT (Advanced Level) Practice - 1045 Favorite Color Stripe (30 分)

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva’s favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva’s favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva’s favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤10
​4
​​ ) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:
For each test case, simply print in a line the maximum length of Eva’s favorite stripe.

Sample Input:
6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6
Sample Output:
7

#include <stdio.h>
#include <string.h>
int main(){
    int n,m,p,i,j,k;
    scanf("%d%d",&n,&m);
    int a[n+1],t;               //a[i] 表示元素i的出现顺序为a[i]
    memset(a,-1,sizeof(a));     //不是想要的元素 他的顺序就是-1
    for(i=1;i<=m;i++){
        scanf("%d",&t);
        a[t]=i;
    }
    scanf("%d",&p);
    int b[p+1],st[p+1],max=0;   //st[i]代表 以第i个元素作为结尾时 最大长度为多少
    b[0]=0;                     //初始化 作为边界
    st[0]=0;                    //初始化 作为边界
    for(i=1;i<=p;i++){
        scanf("%d",&b[i]);
        if(a[b[i]]==-1) st[i]=st[i-1];  //该元素不是想要的元素 则直接继承前面的长度
        else{
            for(j=i-1;j>0;j--){         //寻找上一个想要的 且 不比本元素顺序靠后的 元素
                if(a[b[j]]!=-1 && a[b[j]]<=a[b[i]]) break;
            }
            st[i]=st[j]+1;              //长度则比该元素长1
            if(st[i]>max) max=st[i];    //更新最大值
        }
    }
    printf("%d",max);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值