卡码网语言基础课|13.链表的基础操作I

这节课了解了Java中链表的构造。

题目描述

构建一个单向链表,链表中包含一组整数数据。输出链表中的所有元素。

要求:
1. 使用自定义的链表数据结构
2. 提供一个 LinkList 类来管理链表,包含构建链表和输出链表元素的方法
3. 在 main 函数中,创建一个包含一组整数数据的链表,然后调用链表的输出方法将所有元素打印出来

输入描述

包含多组测试数据,输入直到文件尾结束。 

每组的第一行包含一个整数 n,表示需要构建的链表的长度。 

接下来一行包含 n 个整数,表示链表中的元素。

输出描述

每组测试数据输出占一行。
按照顺序打印出链表中的元素,每个元素后面跟一个空格。

输入示例

5
1 2 3 4 5
6
3 4 5 6 7 8

输出示例

1 2 3 4 5
3 4 5 6 7 8

 Java实现链表:

import java.util.Scanner;
//链表类:成员有头节点和链表长度
class LinkList{
    public static class Node{//内部类:节点
        int data;
        Node next;
        public Node(int data){
            this.data=data;
            this.next=null;
        }
    }
    
    private Node head;//头节点
    private int length;//链表长度
    
    public LinkList(){//构造函数
        this.head=null;
    }
    
    //插入数据
    public Node insert(int data){
        this.length++;//链表长度+1
        Node newNode=new Node(data);
        if(this.head==null){//当前链表为空
            this.head=newNode;//插入节点为头节点
            return this.head;
        }else{//当前链表非空
            Node currentNode=this.head;
            while(currentNode.next!=null){
                currentNode=currentNode.next;
            }//插入链表尾部
            currentNode.next=newNode;
            return newNode;
        }
    }
    
    public void printList(){//输出链表
        Node currentNode=this.head;
        while(currentNode!=null){
            System.out.printf("%d%c",currentNode.data,currentNode.next==null?'\n':' ');
            currentNode=currentNode.next;
        }
    }
}

public class Main{
    public static void main(String[] args){
        Scanner sc=new Scanner(System.in);
        while(sc.hasNext()){
            int n=sc.nextInt();
            LinkList myList=new LinkList();
            for(int i=0;i<n;i++){
                myList.insert(sc.nextInt());
            }
            myList.printList();
        }
        sc.close();
    }
}

注意29行与39行的区别,到底是当前节点为空,还是当前节点的next指针为空。

好的,我知道了。以下是对您的问题的回答: a. 动态分配内存的方法有很多,可以使用C语言的malloc函数,也可以使用C++中的new操作符,具体方法如下: C语言的malloc函数: ```c struct ListNode* node = (struct ListNode*)malloc(sizeof(struct ListNode)); ``` C++中的new操作符: ```c++ ListNode* node = new ListNode(); ``` b. 初始化单链表需要对链表节点的成员变量进行赋值,以下是一个示例: ```c++ struct ListNode { int val; ListNode* next; ListNode(int x) : val(x), next(NULL) {} }; ListNode* head = NULL; ``` c. 头插法创建单链表的示例代码如下: ```c++ ListNode* head = new ListNode(); head->next = NULL; for (int i = 0; i < n; i++) { int x; cin >> x; ListNode* node = new ListNode(x); node->next = head->next; head->next = node; } ``` 尾插法创建单链表的示例代码如下: ```c++ ListNode* head = new ListNode(); head->next = NULL; ListNode* tail = head; for (int i = 0; i < n; i++) { int x; cin >> x; ListNode* node = new ListNode(x); node->next = NULL; tail->next = node; tail = node; } ``` d. 取链表某一位的值可以通过遍历链表来实现,以下是一个示例: ```c++ ListNode* p = head->next; int pos = 3; for (int i = 1; i < pos && p != NULL; i++) { p = p->next; } if (p == NULL) { cout << "链表长度不足" << endl; } else { cout << p->val << endl; } ``` e. 在链表的某一位进行插入操作可以通过遍历链表找到插入位置,然后插入一个新节点来实现,以下是一个示例: ```c++ ListNode* p = head; int pos = 3; for (int i = 1; i < pos && p != NULL; i++) { p = p->next; } if (p == NULL) { cout << "链表长度不足" << endl; } else { int x = 100; ListNode* node = new ListNode(x); node->next = p->next; p->next = node; } ``` f. 遍历链表可以通过循环遍历链表节点来实现,以下是一个示例: ```c++ ListNode* p = head->next; while (p != NULL) { cout << p->val << " "; p = p->next; } cout << endl; ```
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值