1099 Build A Binary Search Tree (30 分)

1099 Build A Binary Search Tree (30 分)
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

在这里插入图片描述

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:
For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

这一题求二叉排序树的层序遍历结果,从图片可以看出,直接以输入的序列作为节点插入的顺序是不对的
所以关键在于利用二叉排序树的性质:二叉排序树中序遍历结果是一个从小到大的有序序列来构造二叉排序树即可
剩余需注意的点看代码注释

#include <iostream>
#include <queue>
#include <algorithm>
using namespace std;
const int maxn = 110;
struct Node
{
	int data;
	int lchild,rchild;
};
int n;
Node node[maxn];
int inO[maxn];
int num = 0;
//以中序序列构造二叉排序树
//用num来为data赋值,因为排序完之后,数字的顺序改变了
void inOrder(int root)
{
	if (root == -1)
		return;
	inOrder(node[root].lchild);
	node[root].data = inO[num];
	num++;
//	cout << node[root].data << " ";
	inOrder(node[root].rchild);
}
//层序遍历
void BFS(int root)
{
	queue<int> q;
	q.push(root);
	int count = 0;
	while (!q.empty())
	{
		int front = q.front();
		q.pop();
		cout << node[front].data;
		count++;
		if (count != n )
			cout << " ";
		if (node[front].lchild != -1)
			q.push(node[front].lchild);
		if (node[front].rchild != -1)
			q.push(node[front].rchild);

	}
}
int main()
{
	cin >> n;
	for (int i = 0; i < n; i++)
		cin >> node[i].lchild >> node[i].rchild;
	for (int i = 0; i < n; i++)
		cin >> inO[i];
	sort(inO, inO + n, less<int>());
	inOrder(0);
//	cout << endl;
	BFS(0);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值