高精度运算模板hd1002

A + B Problem II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 549890 Accepted Submission(s): 104878

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
题意就是算两个数的和并按一定格式输出

#include<iostream>
#include<cstring>
#include<cmath>
using namespace std; 
int main(){
	int t,c;
	string s1,s2;
	int a[10008],b[10008];
	int len;
	cin>>t;
	c=0;
	while(t--){
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		cin>>s1>>s2;
		a[0]=s1.length();
		for(int i=1;i<=a[0];i++){
			a[i]=s1[a[0]-i]-'0';//将s1以数字形式存在数组a
		}
		b[0]=s2.length();
		for(int i=1;i<=b[0];i++){//存s2
			b[i]=s2[b[0]-i]-'0';
		}
		
		for(int i=1;i<=len;i++){
		a[i]+=b[i];//求和
		a[i+1]+=a[i]/10;
		a[i]%=10; //处理进位
	}
	len=(a[0]>b[0]?a[0]:b[0]);
	len++;(和的长度取s1 s2中长的加一;
	while((a[len]==0)&&len>1) len--;//最终和的长度
		cout<<"Case "<<++c<<':'<<endl;
	cout<<s1<<' '<<'+'<<' '<<s2<<' '<<'='<<' ';
	for(int i=len;i>=1;i--){
		cout<<a[i];
		if(i==1){
			printf("\n");
		}
	}
if(t!=0)printf("\n");//特别注意,最后一组不用换行了,(我在这里pe了好久555)
}} 
//1 + 2 = 3
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值