题目描述
Time Limit: 1000 ms
Memory Limit: 256 mb
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。
输入输出格式
输入描述:
测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M (N, M < =100 );随后的 N 行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。
输出描述:
对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。
输入输出样例
输入样例
3 3
1 2 1
1 3 2
2 3 4
1 3
2 3 2
0 100
输出样例
3
?
#include<bits/stdc++.h>
using namespace std;
struct Edge{
int from;
int to;
int length;
};
const int MAXN=101;
Edge edge[MAXN*MAXN];
int father[MAXN];
int height[MAXN];
void init(int n){
for(int i=0;i<=n;i++){
father[i]=i;
height[i]=0;
}
}
int find(int x){
if(x!=father[x]){
x=find(father[x]);
}
return x;
}
void union1(int x,int y){
int x1=find(x);
int y1=find(y);
//两个结点不在一个集合里
if(x1!=y1){
if(height[x1]<height[y1]){
father[x1]=y1;
}
else if(height[x1]>height[y1]){
father[y1]=x1;
}
else if(height[x1]==height[y1]){
father[y1]=x1;
height[x1]++;
}
}
}
bool bmp(Edge a,Edge b){
return a.length<b.length;
}
int Kruscal(int m,int n){
init(m);
int result=0;
sort(edge,edge+n,bmp);
for(int i=0;i<n;i++){
Edge current;
current=edge[i];
if(find(current.from)!=find(current.to)){
union1(current.from,current.to);
result+=current.length;
}
}
return result;
}
int main(){
int n,m,flag;
while(cin>>n>>m){
flag=0;
if(n==0){
break;
}
for(int i=0;i<n;i++){
cin>>edge[i].from>>edge[i].to>>edge[i].length;
}
int result=Kruscal(m,n);
for(int j=1;j<=m;j++){
if(find(j)==j){
flag++;
}
}
if(flag>1){
cout<<"?"<<endl;
}
else{
cout<<result<<endl;
}
}
return 0;
}