PAT 1027 Colors in Mars

该博客介绍了一个编程问题,涉及将十进制颜色值转换为火星上的十三进制表示。输入为三个十进制数(红色、绿色和蓝色),输出为格式化的火星RGB值。提供的C++代码示例展示了如何实现这一转换,通过将十进制数字拆分为十三进制,并使用字符数组表示每个颜色分量。代码简洁高效,适合学习和理解不同基数转换的原理。
摘要由CSDN通过智能技术生成

1027 Colors in Mars

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

总结:这题还是很简单的,没有太多的坑(坑的地方也已经说明了),直接将十进制数转换成十三进制数就行了

 这里比较好的处理方式是将所有结果的数字都存储在char类型的数组中,这样可以减少很多不必要的判断

#include <iostream>
using namespace std;

int main(){
    int a[3];
    char digit[]={'0','1','2','3','4','5','6','7','8','9','A','B','C'};
    cin >> a[0] >> a[1] >> a[2];
    
    printf("#");
    for(int i=0;i<3;i++){
        string s;
        if(a[i]>=13)    s+=(digit[a[i]/13]);
        else s+='0';
        s+=(digit[a[i]%13]);
        cout << s;
    }
    
    return 0;
}

依照惯例,看看大佬的代码:

果然,还是被打击了,真的是太厉害了,膜拜!

#include <cstdio>
using namespace std;
int main() {
    char c[14] = {"0123456789ABC"};
    printf("#");
    for(int i = 0; i < 3; i++) {
        int num;
        scanf("%d", &num);
        printf("%c%c", c[num/13], c[num%13]);
    }
    return 0;
}

好好学习,天天向上!

我要考研!

2022.11.2

#include <iostream>
using namespace std;

int main(){
    int a,b,c;
    scanf("%d%d%d",&a,&b,&c);
    char color[]="0123456789ABC";//0~12
    
    printf("#%c%c",color[a/13],color[a%13]);
    printf("%c%c",color[b/13],color[b%13]);
    printf("%c%c",color[c/13],color[c%13]);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值