PAT 1058 A+B in Hogwarts(模拟)

1058 A+B in Hogwarts

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

总结:这道题目还是比较简单的,模拟正常的加法操作即可,注意进位!

#include <iostream>
using namespace std;

int main(){
    int ga,sa,ka,gb,sb,kb,g=0,s=0,k=0;
    scanf("%d.%d.%d %d.%d.%d",&ga,&sa,&ka,&gb,&sb,&kb);

    int t=0;
    k=kb+ka;
    if(k>=29){
        k%=29;
        t=1;
    }
    s=t+sa+sb;
    t=0;
    if(s>=17){
        s%=17;
        t=1;
    }
    g=ga+gb+t;
    printf("%d.%d.%d\n",g,s,k);
    
    return 0;
}

看看大佬的,说不定有收获呢!

惭愧,又是膜拜的一天

#include <iostream>
using namespace std;

int main(){
    int ga,sa,ka,gb,sb,kb,g=0,s=0,k=0;
    scanf("%d.%d.%d %d.%d.%d",&ga,&sa,&ka,&gb,&sb,&kb);
    
    k=(ka+kb)%29;s=(ka+kb)/29;
    g+=(s+sa+sb)/17;s=(s+sa+sb)%17;
    //因为s本身存了上一位的进位,需要先计算g,在计算s,如果先计算s,那么进位就没了
    g+=ga+gb;
    
    printf("%d.%d.%d\n",g,s,k);
    
    return 0;
}

好好学习,天天向上!

我要考研!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,这个测试场景我可以用 Python 的 selenium 库进行自动化测试。以下是大致的测试代码: ```python from selenium import webdriver from selenium.webdriver.common.keys import Keys import time # 登录账户 driver = webdriver.Chrome() driver.get("https://thingsboard.hogwarts.ceshiren.com/") elem = driver.find_element_by_name("username") elem.send_keys("1945075385@qq.com") elem = driver.find_element_by_name("password") elem.send_keys("hogwarts") elem.send_keys(Keys.RETURN) time.sleep(5) # 新增设备 driver.get("https://thingsboard.hogwarts.ceshiren.com/dashboard/3f7d7b20-7b43-11eb-bd5a-3f8ae6b9bcbc") elem = driver.find_element_by_class_name("add-button") elem.click() time.sleep(1) elem = driver.find_element_by_class_name("tb-create-entity-type-select") elem.click() time.sleep(1) elem = driver.find_element_by_xpath("//div[@class='tb-create-entity-type-select']/div[2]/div[1]/div[1]") elem.click() time.sleep(1) elem = driver.find_element_by_class_name("tb-create-entity-form") elem = elem.find_element_by_xpath("//input[@placeholder='Device name']") elem.send_keys("Test Device") elem = driver.find_element_by_xpath("//input[@placeholder='Serial number']") elem.send_keys("123456") elem = driver.find_element_by_class_name("tb-create-entity-footer") elem = elem.find_element_by_xpath("//button[@type='submit']") elem.click() time.sleep(5) # 修改设备 elem = driver.find_element_by_xpath("//span[text()='Test Device']") elem.click() time.sleep(1) elem = driver.find_element_by_xpath("//input[@name='name']") elem.clear() elem.send_keys("New Test Device") elem = driver.find_element_by_xpath("//input[@name='type']") elem.clear() elem.send_keys("New Test Type") elem = driver.find_element_by_xpath("//input[@name='key']") elem.clear() elem.send_keys("New Test Key") elem = driver.find_element_by_xpath("//button[@type='submit']") elem.click() time.sleep(5) # 删除设备 elem = driver.find_element_by_xpath("//span[text()='New Test Device']") elem.click() time.sleep(1) elem = driver.find_element_by_class_name("tb-delete-entity-button") elem.click() time.sleep(1) elem = driver.find_element_by_xpath("//button[text()='Delete']") elem.click() time.sleep(5) # 关闭浏览器 driver.close() ``` 需要注意的是,我使用的是 Chrome 浏览器,所以需要下载对应版本的 chromedriver 并放在系统环境变量中。另外,测试过程中需要等待页面加载,所以我使用了 time.sleep() 函数来进行等待。如果网速较快,可以适当减少等待时间。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值