本题要求编写程序,从给定字符串中查找某指定的字符。
输入格式:
输入的第一行是一个待查找的字符。第二行是一个以回车结束的非空字符串(不超过 80 个字符)。
输出格式:
如果找到,在一行内按照格式 “index = 下标” 输出该字符在字符串中所对应的最大下标(下标从 0 开始);否则输出 “Not Found”。
输入样例1:
m
programming
输出样例1:
index = 7
输入样例2:
a
1234
输出样例2:
Not Found
来源:
来源:PTA | 程序设计类实验辅助教学平台
链接:https://pintia.cn/problem-sets/12/exam/problems/322
提交:
题解:
#include<stdio.h>
int main(void) {
char target = (char) getchar();
// 吸收输入 target 后回车产生的换行符
getchar();
char string[81];
gets(string);
int index = -1;
for (int i = 0; string[i] != '\0'; i++) {
if (string[i] == target) {
index = i;
}
}
if (index == -1) {
printf("Not Found");
} else {
printf("index = %d", index);
}
return 0;
}