1015 Reversible Primes

题目来源:PAT (Advanced Level) Practice

A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

words:

Reversible 可逆的,逆向的        prime 主要的,基本的,质数        decimal 十进制的       

radix 进制,基数

思路:

1. 首先写一个函数prime()用于判断一个数n是否为质数;

2. 再写一个函数radix_reverse()用于返回一个数n的d进制形式的逆序所对应的十进制数;

3. 使用上述函数判断输入的数n是否为 reversible prime;

//PAT ad 1015 Reversible Primes
#include <iostream>
using namespace std;
#include <cmath>

bool prime(int n)	//判断n是否为质数
{
	if(n==0||n==1)	return false;
	for(int i=2;i*i<=n;i++)
		if(n%i==0)
			return false;
	return true; 
} 

int radix_reverse(int n,int d)  //将十进制n转化为d进制数,然后反序后再转化为10进制数 
 
{
	int ans=0;
	while(n)	//十进制n转化为d进制数并反序 
	{
		int t=n%d;
		n/=d;
		ans=ans*10+t;		//反序
	}
	if(d==10)	return ans;

	int k=0;
	n=ans;ans=0;
	while(n)	//将反序后的数再转化为10进制数 
	{
		int t=n%10;
		n/=10;
		ans+=t*pow(d,k++);
	}
	return ans;
}
int main()
{
	int n,d;
	while(1)
	{
		cin>>n;
		if(n<0)	break;
		cin>>d;
		bool f1=prime(n);   //判断n是否为质数 
		bool f2=prime(radix_reverse(n,d));		//判断n的反序是否为质数 
		
		if(f1&&f2)	cout<<"Yes"<<endl;
		else	cout<<"No"<<endl;
	}
	
	return 0;
 } 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值