1042 Shuffling Machine

题目来源:PAT (Advanced Level) Practice

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

words:

Shuffling 洗牌        procedure程序,过程        randomize 使随机化,完全打乱       gambler 赌徒

 collaborate        合作,勾结        inadequate 不充分的,不足的        casinos 赌场        

simulate 模拟,模仿        Spade 黑桃♠        Hear 红桃♥        Club 梅花♣        Diamond 方块♦

permutation 序列,排列

思路:

1. 通过给定的数k序列sh[54]给扑克牌洗牌,,k为洗牌的次数,序列sh[]为洗牌的要求,即将i位置上的牌放置到sh[i]位置处,由于序列中的每个数都是不同的,所以对每一张牌按要求放置后刚好占完所有位置;

2. 使用pair<string,int>类型的数组p[54]来保存扑克牌;

3. 将序列sh[54]中的第i个元素赋给p[54]中第i个元素的second,然后对数组p[54]按照second从小到大排序即可完成一次洗牌(效果等同于将每一张牌按照要求放置到相应的位置);若需要多次洗牌则重复执行此步骤;

//PAT ad 1042 Shuffling Machine 
#include <iostream>
using namespace std;
#include <algorithm> 
#include <string>

pair<string,int> p[54];

void Initial()		//初始化 
{
	char SHCD[4]={'S','H','C','D'};
	for(int i=0;i<52;i++)
	{
		char c=SHCD[i/13];
		p[i].first=c+to_string(i%13+1);	
	}
	p[52].first="J1";
	p[53].first="J2";
}

void print()	//打印
{
	int i=0;
	for(i=0;i<53;i++)
		cout<<p[i].first<<" ";
	cout<<p[i].first<<endl;
 } 
 
bool cmp(pair<string,int> x,pair<string,int> y)
{
	return x.second<y.second;
}

void shuttle(int *sh)	//按照数组sn的要求进行洗牌 
{
	for(int i=0;i<54;i++)
		p[i].second=sh[i];
	sort(p,p+54,cmp);	//排序,相当于一次洗牌	 
}
int main()
{
	int n,sh[54];
	cin>>n;
	for(int i=0;i<54;i++)
		cin>>sh[i];
	Initial(); //初始化 
	while(n--)  //n此洗牌 
		shuttle(sh); 
	print(); 	//打印 
	return 0;
 } 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值