1101 Quick Sort

题目来源:PAT (Advanced Level) Practice

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then the next line contains N distinct positive integers no larger than 10​9​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

word:

partition 隔断,分治        pivot 枢轴        candidates 候选人        adjacent 邻近的

思路:

1. 本题的意思是从给定的一个数列中找出可以作为快速排序划分前选取的主元;主元要求其左侧的元素都小于等于它,其右侧的元素都大于等于它,所以本题中找出数列中满足这两点的元素即可;

2. 从头到尾遍历数组,找出区间[0,i]的最大值并记录在m1[i]中;

3. 从尾到头遍历数组,找出区间[i,n-1]的最小值并记录在m2[i]中;

4. 遍历数组,判断a[i]是否区间[0,i]的最大值和区间[i,n-1]的最小值,即m1[i]<=a[i]&&m2[i]>=a[i];若是则a[i]可能是主元,则记录以备输出;

5. 输出主元的个数并且从小到大输出主元,若主元的个数为0,则输出0和一个空行;

//1045 快速排序
#include <iostream>
using namespace std;
#include <vector>
#include <algorithm>

vector<int> ans;

int main()
{
    int n,i;
    cin>>n;
    int a[n];
    int m1[n];
    int ma=0;
    for(i=0;i<n;i++)        //找出区间[0,i]中的最大值,并保存到数组m1中
    {
        cin>>a[i];
        ma=max(a[i],ma);
        m1[i]=ma;
    }
    int m2[n];
    int mi=1000000005;
    for(i=n-1;i>=0;i--)     //找出区间[i,n-1]中的最小值,并保存到数组m2中
    {
        mi=min(a[i],mi);
        m2[i]=mi;
    }

    for(i=0;i<n;i++)     //寻找主元
        if(m1[i]<=a[i]&&m2[i]>=a[i])
            ans.push_back(a[i]);

    cout<<ans.size()<<endl;
    if(ans.empty())   //主元数为0时
    {
        cout<<endl;return 0;
    }

    sort(ans.begin(),ans.end());
    for(i=0;i<ans.size()-1;i++)   //输出主元
        cout<<ans[i]<<" ";
    cout<<ans[i]<<endl;

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Quick sort is a popular sorting algorithm that works by partitioning an array into two sub-arrays, and then recursively sorting each sub-array. It is a divide-and-conquer algorithm that has an average time complexity of O(n log n), making it one of the fastest sorting algorithms. The basic idea behind quick sort is to select a pivot element, partition the array around the pivot element, and then recursively apply the same process to each of the sub-arrays. The partitioning process involves selecting a pivot element, rearranging the array so that all elements less than the pivot are on one side and all elements greater than the pivot are on the other side, and then returning the index of the pivot element. This pivot index is then used to divide the array into two sub-arrays, which are recursively sorted. Here's an example implementation of quick sort in Python: ``` def quick_sort(arr): if len(arr) <= 1: return arr else: pivot = arr[0] left = [] right = [] for i in range(1, len(arr)): if arr[i] < pivot: left.append(arr[i]) else: right.append(arr[i]) return quick_sort(left) + [pivot] + quick_sort(right) ``` This implementation selects the first element of the array as the pivot, and then uses list comprehensions to create the left and right sub-arrays. The left sub-array contains all elements less than the pivot, while the right sub-array contains all elements greater than or equal to the pivot. The function then recursively sorts the left and right sub-arrays and combines them with the pivot element to produce the final sorted array.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值