「1101」Quick Sort

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer  . Then the next line contains N distinct positive integers no larger than 109. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

Ω

在快速排序中经常需要设定一个 ,我们把 放它左边, 的放它右边,然后递归分治。那么给出一个快排序列,请输出其中的哪些数可能是

比较简单,首先可以肯定的一点是 所处的位置一定和排序后的位置相同,因此我们先对原序列sort一下,然后从头开始遍历,如果当前位置元素与排序后元素不同就直接跳过(⚠️跳过时别忘记录当前最大值),否则比较左边最大元素与当前元素的大小,如果小于当前元素就说明比它小的数都在左边,那么就是 ,然后更新当前(左边)最大元素。

由于 们所处位置就是排序后的位置,因此从头开始遍历一定是按照升序压入的,最后就无需sort了,按顺序输出即可。

o,有个极其离谱的测试点(case 2),就是0的时候需要回车两次,也就是需要把列举pivot的那一列空出来,不知道咋想的,孩子已经很久没有Presentation Error了(−_−#)。


🐎

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

int main()
{
    int n, left_max = -1;
    cin >> n;
    vector<int> seq(n);
    for (auto &k: seq)
        cin >> k;
    vector<int> copy(seq), ans;
    sort(copy.begin(), copy.end());
    for (int i = 0; i < n; ++i)
    {
        left_max = max(left_max, seq[i]);
        if (copy[i] != seq[i]) continue;
        if (left_max <= seq[i]) ans.push_back(seq[i]);
    }
    if (ans.empty()) printf("0\n\n");
    else
    {
        printf("%zu\n%d", ans.size(), ans[0]);
        for (int i = 1; i < ans.size(); ++i)
            printf(" %d", ans[i]);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值