1063 Set Similarity

本文介绍了一种算法,用于解决PAT高级水平的题目,计算给定两个整数集合的相似度,即它们共有元素数量占各自独特元素总数的比例,结果以百分比形式保留一位小数。通过集合操作实现高效查询,适用于PAT中的相似度问题求解。
摘要由CSDN通过智能技术生成

题目来源:PAT (Advanced Level) Practice

Given two sets of integers, the similarity of the sets is defined to be N​c​​/N​t​​×100%, where N​c​​ is the number of distinct common numbers shared by the two sets, and N​t​​ is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤10​4​​) and followed by M integers in the range [0,10​9​​]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

word:

similarity 相似性,相似度        distinct 不同的        common 共同的        pair 一对

题意:

在给定的n个集合中,计算任意两个集合的相似度(两个集合相同的元素个数与两个集合并集的元素个数之比),结果以百分数形式输出,保留一位小数;

思路:

1. 使用集合数组分别保存n个集合的元素;

2. 集合a和b的相似度:初始时相同元素个数same=0总元素个数total等于b的元素个数,遍历集合a,查找a中的每一个元素是否在b中存在,若存在则说明该元素重复same++,否则total++

3. 输出集合的相似度same/total*100%(保留一位小数),并进行下一对集合的查询;

4.第2步也可以使用set_intersection()set_union()这两个求交集和并集的函数来做,但这样最后一个测试点会超时;

//PAT ad 1063 Set Similarity 
#include <iostream>
using namespace std;
#include <set>
#include <iomanip>
#include <algorithm>

int main()
{
	int n,i,x,m;
	cin>>n;
//	scanf("%d",&n); 
	set<int> s[n];		//集合数组 
	for(i=0;i<n;i++)		//输入 
	{
		cin>>m;
//		scanf("%d",&m);
		while(m--)
		{
			cin>>x;
//			scanf("%d",&x);
			s[i].insert(x);
		}
	}
	int k,a,b;
	cin>>k;
	//scanf("%d",&k);
	while(k--)
	{
		cin>>a>>b;		//集合号 
		int same=0,total=s[b-1].size();
		for(auto w:s[a-1])
		{
			if(s[b-1].find(w)!=s[b-1].end())	//该元素重复
				same++;
			else
				total++;
		}
//		set<int> jiao,bing;
//		set_intersection(s[a-1].begin(),s[a-1].end(),s[b-1].begin(),s[b-1].end(),inserter(jiao,jiao.begin()));	//交集合 
//		set_union(s[a-1].begin(),s[a-1].end(),s[b-1].begin(),s[b-1].end(),inserter(bing,bing.begin()));		//并集
		cout<<fixed<<setprecision(1)<<same*100.0/total<<"%"<<endl;		//集合a 和b的相似度 
		//printf("%.1f%c\n",same*100.0/total,'%'); 
	}
	
	
	return 0;
 } 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值