1063 Set Similarity (25point(s)) - PAT 甲级 C语言

1063 Set Similarity (25point(s))

Given two sets of integers, the similarity of the sets is defined to be Nc / Nt × 100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤ 50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤ 104) and followed by M integers in the range [0,109]. After the input of sets, a positive integer K (≤ 2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

题目大意:

给多个集合,多次查询两个集合,输出每次查询的两个集合的相似度 Nc / Nt * 100%,Nc 为两集合中公共元素的个数,Nt 为两集合中不同元素的总个数,即 Nc 为两集合的交集,Nt 为并集

设计思路:
  • 对每个集合排序去重,
  • 经过排序,集合元素有序,查询两集合时,用两个指针从前往后遍历集合
    • 两指针元素相同,两指针同时向后走,Nc 和 Nt 均加 1
    • 指针元素不同,谁小谁向后走,仅 Nt 加 1
    • 最后将 Nt 加上未遍历完集合的剩余元素个数
  • 输出查询结果
编译器:C (gcc)
#include <stdio.h>

int cmp(const void *a, const void *b)
{
        return *((int *)a) - *((int *)b);
}

int sort_uniq(int arr[], int n)
{
        int i, j;
        qsort(arr, n, sizeof(arr[0]), cmp);

        for (i = 1, j = 0; i < n; i++) {
                if (arr[i] != arr[j]) {
                        arr[++j] = arr[i];
                }
        }
        return j + 1;
}

int main(void) {
        int n, m, k;
        int sets[50][10001] = {0}, count[50] = {0};
        int i, j, temp;
        int a, b, nc, nt;

        scanf("%d", &n);
        for (i = 0; i < n; i++) {
                scanf("%d", &m);
                for (j = 0; j < m; j++) {
                        scanf("%d", &sets[i][j]);
                }
                count[i] = sort_uniq(sets[i], m);
        }

        scanf("%d", &k);
        for (m = 0; m < k; m++) {
                scanf("%d %d", &a, &b);
                a--;
                b--;
                nc = 0;
                nt = 0;
                for (i = 0, j = 0; i < count[a] && j < count[b];) {
                        if (sets[a][i] == sets[b][j]) {
                                nc++;
                                nt++;
                                i++;
                                j++;
                        } else {
                                nt++;
                                if (sets[a][i] < sets[b][j])
                                        i++;
                                else
                                        j++;
                        }
                }
                if (i < count[a])
                        nt = nt + count[a] - i;
                else
                        nt = nt + count[b] - j;
                printf("%.1f%%\n", (double)nc / nt * 100);
        }
        return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值