1113 Integer Set Partition

题目来源:PAT (Advanced Level) Practice

Given a set of N (>1) positive integers, you are supposed to partition them into two disjoint sets A​1​​ and A​2​​ of n​1​​ and n​2​​ numbers, respectively. Let S​1​​ and S​2​​ denote the sums of all the numbers in A​1​​ and A​2​​, respectively. You are supposed to make the partition so that ∣n​1​​−n​2​​∣ is minimized first, and then ∣S​1​​−S​2​​∣ is maximized.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤10​5​​), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 2​31​​.

Output Specification:

For each case, print in a line two numbers: ∣n​1​​−n​2​​∣ and ∣S​1​​−S​2​​∣, separated by exactly one space.

Sample Input 1:

10
23 8 10 99 46 2333 46 1 666 555

Sample Output 1:

0 3611

Sample Input 2:

13
110 79 218 69 3721 100 29 135 2 6 13 5188 85

Sample Output 2:

1 9359

words:

Partition 隔离,分割        disjoint 解体,脱节       

题意: 

将给定的n个数分为两组,两组的元素个数分别位n1和n2,元素和为s1和s2,分割的时候首先使|n1-n2|最小,然后使|s1-s2|最大

思路:

1. 将n个元素进行排序,从小到大;

2. 将前面n/2个元素分为一组(n1=n/2),剩余的元素为另一组(n2=n-n/2),并分别求他们的和s1和s2;

3. 输出n2-n1和s2-s1;

//PAT ad 1113 Integer Set Partition
#include <iostream>
using namespace std; 
#include <algorithm>

int main()
{
	int n,i;
	cin>>n;
	int a[n];
	for(i=0;i<n;i++)
		cin>>a[i];
	
	sort(a,a+n);		//升序排序 

	int s1=0,s2=0;
	int m=n/2; 
	for(i=0;i<m;i++)		//求s1 
		s1+=a[i];
	for(;i<n;i++)			//求s2 
		s2+=a[i];
	 
	cout<<n-m-m<<" ";			//n1-n2 
	cout<<s2-s1<<endl;			//s1-s2
	
	return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值