1069 The Black Hole of Numbers

题目来源:PAT (Advanced Level) Practice

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,10​4​​).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

words:

manner 方式,方法        black hole 黑洞        illustrate 说明        equation 等式,方程式

题意:

将输入的任意一个四位数n(4位数字不完全相同)的数字先按照降序排列得到新的四位数a,再按照升序排列得到新的四位数b,计算a-b得到新的n,不断如此重复直到n等于6174;

思路:

1. 输入一个数n后不断进行模拟即可;当n输入的不是四位数时需要给前面补‘0’达到四位数

2. 再模拟过程中若a==b,即n=0,此时停止模拟、输出”0000“结束

3. 当一个数在输出时不满四位数,则前面补‘0’

//1019 数字黑洞
#include <iostream>
using namespace std;
#include <algorithm>
#include <iomanip>

bool cmp(char x,char y) //递减排序
{
    return x>y;
}

int num(string s)		//将字符串s转化为数值形式 
{
	int ans=0;
	while(!s.empty())
	{
		ans=ans*10+s[0]-'0';
		s.erase(0,1);
	}
	return ans; 
}

int main()
{
    string s;
    int a,b;
    cin>>s;    //以字符串的形式输入数n 
    
    do
    {
    	while(s.size()<4)	//若输入的数为[1,999],则补足为4位数 
    		s="0"+s;
        sort(s.begin(),s.end(),cmp);  //递减排序 
        a=num(s);

        sort(s.begin(),s.end());    //递增排序 
        b=num(s);
        
        if(a==b)
            s="0000";
        else
            s=to_string(a-b);
        cout<<setw(4)<<setfill('0')<<a<<" - ";
        cout<<setw(4)<<setfill('0')<<b<<" = ";
		cout<<setw(4)<<setfill('0')<<s<<endl;

    }while(s!="0000"&&s!="6174");

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值