1094 The Largest Generation

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

words:

hierarchy 层次,分层        pedigree 族谱        present 展示,显示        

题意:

给定n个结点以及m个结点的孩子信息(根结点为1)的族谱树,求结点最多的一层的结点数和其层数(根节点的层数为1);

思路:

1. 使用有向图来表示族谱树,使用邻接表来存储有向图;

2. 输入结点信息并创建有向图,令所有边的方向为父结点指向孩子结点

3. BFS遍历有向图,使用数组nums[]记录每一层的结点个数

4. 找出nums[]中最大的结点个数以及其对应的层数,并输出;

//PAT ad 1094 The Largest Generation
#include <iostream>
using namespace std;
#include <set>
#include <algorithm>
#include <queue>
#include <vector>
#define N 105

int const root=1;	//根
int nums[N]={0};	//记录每层的结点数 

void BFS(vector<set<int> > &adj)		//BFS遍历图,统计每层的结点数 
{
	queue<int> qe;
	qe.push(root);
	int c=0;
	int n=qe.size();
	int level=1;
	
	while(!qe.empty())
	{
		int x=qe.front();qe.pop();
		nums[level]++;		//该层结点数+1 
		for(auto w:adj[x])	//遍历孩子 
			qe.push(w);
		c++;
		if(c==n)	//用于区分层与层 
		{
			level++;
			c=0;
			n=qe.size();
		}
	}	
}
int main()
{
	int n,m,i;
	cin>>n>>m;
	vector<set<int> > adj(n+1);		//邻接表 
	int id,k;
	for(i=0;i<m;i++) 	//输入 
	{
		cin>>id>>k;
		int child;
		while(k--)
		{
			cin>>child;
			adj[id].insert(child);	//用邻接表存储有向图,用有向图存储表示族谱 
		}	
	}
	
	BFS(adj); 		//层序遍历有向图 
	
	int index=0;	//最多人数的层 
	int ma=0;		//最多人数 
	for(i=1;i<=n;i++)	//找到最多人数的层 
		if(nums[i]>ma)
		{
			ma=nums[i];
			index=i;
		}

	cout<<ma<<" "<<index<<endl;	//输出 
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值