1094 The Largest Generation (25)

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (&lt100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (&ltN) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (&gt0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

题目大意是给出树的节点数(下标从1开始,并且规定1是根节点)和非叶子节点数,在给吃非叶子结点的孩子个数,让你计算哪一层的节点数最多(根节点为第一层,并规定根节点只有一个),输出最大的层的节点数和层数

 

#include <iostream>
#include <queue>
#include <stack>
#include <stdio.h>
#include <algorithm>
using namespace std;
struct Node
{
    vector<int> child;
    int layer;
}node[200];
int gen[200];
int main()
{
    for(int i=0; i<200; i++)
        gen[i] = 0;
    int n,m;
    cin>>n>>m;
    int root = 1;
    int indx,Size,num;
    for(int i=0; i<m; i++)
    {
        cin>>indx>>Size;
        for(int j=0; j<Size; j++)
        {
            cin>>num;
            node[indx].child.push_back(num);
        }
    }
    queue<int> q;
    q.push(root);
    gen[root] = 1;
    node[root].layer = 1;
    int maxlayer = 1;
    int cnt = 1;
    while(!q.empty())
    {
        int now = q.front();
        q.pop();
        int len = node[now].child.size();
        for(int i=0; i<len; i++)
        {
            node[node[now].child[i]].layer = node[now].layer + 1;
            gen[node[node[now].child[i]].layer] ++;
            if(gen[node[node[now].child[i]].layer] > maxlayer)
            {
                maxlayer = gen[node[node[now].child[i]].layer];
                cnt = node[node[now].child[i]].layer;
            }
            q.push(node[now].child[i]);
        }
    }
    cout<<maxlayer<<" "<<cnt<<endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

九久呀

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值