1154 Vertex Coloring (25 分)

proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

题意:proper vertex coloring即是图中任意相邻的两点的颜色不能相同,用unordered_set记录整个图有多少的颜色,即是最后的k-coloring,如果图中出现了相邻两点颜色一样则直接输出NO即可

C++:

#include"iostream"
#include"unordered_set"
#include"vector"
#include"algorithm"
using namespace std;
const int maxn=10010;
struct node{
	int a,b;
};
int main(){
	int n,m;
	vector<node> edge;
	scanf("%d %d",&n,&m);
	for(int i=0;i<m;i++){
		int a,b;
		node temp;
		scanf("%d %d",&a,&b);
		temp.a=a;
		temp.b=b;
		edge.push_back(temp);
	}
	int k;
	scanf("%d",&k);
	for(int i=0;i<k;i++){
		unordered_set<int> book;
		vector<int> color(n);
		int flag=1;
		for(int j=0;j<n;j++){
			scanf("%d",&color[j]);
			book.insert(color[j]);
		}
		for(int j=0;j<m;j++){
			int a=edge[j].a,b=edge[j].b;
			if(color[a]==color[b]){
				flag=0;
				break;
			}
		}
		if(flag==0)
			printf("No\n");
		else
			printf("%d-coloring\n",book.size());
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值