ALDS1_4_B: Binary Search

题目
Search II
You are given a sequence of n integers S and a sequence of different q integers T. Write a program which outputs C, the number of integers in T which are also in the set S.

Input
In the first line n is given. In the second line, n integers are given. In the third line q is given. Then, in the fourth line, q integers are given.

Output
Print C in a line.

Constraints
Elements in S is sorted in ascending order
n ≤ 100000
q ≤ 50000
0 ≤ an element in S ≤ 109
0 ≤ an element in T ≤ 109

Sample Input 1
5
1 2 3 4 5
3
3 4 1

Sample Output 1
3

Sample Input 2
3
1 2 3
1
5

Sample Output 2
0

Sample Input 3
5
1 1 2 2 3
2
1 2

Sample Output 3
2
代码块
#include <iostream>
using namespace std;

int BinarySearch(int *a, int n, int key)
{
    int left = 0;
    int right = n-1;
    while(left<=right)
    {
        int mid = (left+right)/2;
        if(key==a[mid])
            return 1;
        else if(key<a[mid])
            right = mid-1;
        else
            left = mid+1;
    }
    return 0;
}

int main(void)
{
    int i, n, q;
    cin>>n;
    int a[n];
    for(i=0; i<n; i++)
        cin>>a[i];
    cin>>q;
    int key;
    int sum = 0;
    for(i=0; i<q; i++)
    {
        cin>>key;
        if(BinarySearch(a, n, key))
            sum++;
    }
    cout<<sum<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值